How to install other linux distri

I received my A06 model . The only working linux distribution is the one sent with the package .

I would like to run kali or dragon os (based on ubuntu arm) and raspi standard . I did a 512 GB card with differents OS and my screen always stay black . I didn’t find the way to make it running . I tried to use rufus or balenaEtcher-Portable-1.18.11 with same results .
Thanks for help

1 Like

The first place you should look is the github, i would like to help more but i have no experience because of not getting one myself yet. There are other threads on here about this same issue if you hunt around.

I think the short answer is that this probably isn’t possible unless you’re a bit of an expert, and know how to patch kernels and trouble-shoot issues that don’t work.

ARM is a bit different from x86 when it comes to the boot process and identifying peripheral hardware. x86 machines have more standardized ways of loading an OS from disk and querying to see which hardware is installed. Arm systems have entirely different ways of doing this, and a kernel prepared for one Arm system will not necessarily boot on another, even if they share the same core.

As computer specialist for 40 years , I m used to differents OS . I have 3 raspi 3 /4 /4 4GB . I have good knowlegde in windows, linux, arm . On raspi I was able to run Kali linux, Dragon _OS, and standard raspi OS. I know how to patch linux kernel . What I want to know is how I can run these OS .

I don’t have received mine but I think that it is kinda tricky to boot other os on the a06 but I think it should be possible on the cm4 I would tell u more if I would receive mine.
Sorry :see_no_evil:

But that is a good question though I’m also interested in it I would say that if it runs on the cm4 u have to get the driver’s for screen keyboard and Trackball,
Maybe that is the solution that u need an seperaten driver

This may sound silly, but did you try plugging in the mini HDMI and see if you get output on that display?

As others have stated… for a cm4 at least… the kernel needs to be patched… I believe it’s because the screen technically isn’t plugged into any hdmi… it’s on the mipi connector… If it boots and you have a black screen… you are gunna need to check the wiring diagrams… correlate with the pin out on your soc… And patch kernel to use correct video connector… I would probably use a dongle… to putty to it and see what you can get into as well…

Hope this helps

Good luck!

I’m also a computer specialist, software engineer, have 20+ years linux experience. I’m saying: still not enough of an expert in this type of hardware. Just because it works on CM4 does not mean it will work on A0x, or any other arm board.

So, since you’re an expert, you hopefully understand when I say the following: the display drivers aren’t upstreamed into mainline linux – It’s just vendor patches on top of a specific linux kernel. Their patches need to be ported to mainline linux, and then wait a couple years, and mainstream distros might support this hardware.

Until then, you need to apply the patches and compile the kernel yourself, perhaps adapting the code as needed, each time you want to update your kernel. There are some folks working on this right now, I prefer to wait until they get a little further, and use the official os images until then.

Folks who ordered these things over a year ago are just finally getting them. But now that they are finally being delivered, I suspect kernel support will improve fairly soon.

1 Like

Sorry English isn’t my native language . If I understood well . I have to follow this :slight_smile:

I change the source code using this :slight_smile:

I run this installation on a standard RASPI then I apply the list of patches

After I boot on clock PI

Is it good ?

I 'm very unhappy . I have wait more than a year to make only working with the original

I can’t run KALI , I can’t run dragon OS ubuntu arm .

There is so few informations on products .

If you go into the folder of your choice of core (a06, cm4…) on the github, there should be a little more info on getting your own choice of os working

Those instructions are junk to be honest. Unless you’re skilled with that kind of stuff, it’s going to be extremely difficult. It also only works with one kernel version at this moment.
There really needs to be proper documentation on the hardware and what the patches actually do so the kernel can properly be supported.

ClockworkPi seems to be run in a similar style to pine64 “here’s hardware with kinda-sorta drivers, good luck.” Which is fine, but really could be improved upon as the community around ClockworkPi is much smaller, so community support is not as good. Yet…

1 Like

Seeedstudio is the same. They make neat hardware, but sometimes updates totally break it until they make a patch.

I spent more than a year to get my clockpi and I can’t install other stuff than the :slight_smile:

I tried to make a new one using dragon OS raspi 5

I run on a raspi 5 working fine

I did apt-get update, upgrade and disk-upgrade

Then I apply the patch

git clone -b master 

cd build

mkdir -p userpatches/kernel/rockchip64-current/


wget -O userpatches/kernel/rockchip64-current/z-10000_a06_sound_230701.patch
wget -O userpatches/kernel/rockchip64-current/z-10000_a06_uc_panel_230701.patch 

git apply

./  BOARD=clockworkpi-a06 BRANCH=current BUILD_MINIMAL=no BUILD_DESKTOP=no BUILD_ONLY=u-boot,kernel,armbian-config,armbian-zsh,plymouth-theme-armbian,armbian-firmware,armbian-bsp KERNEL_CONFIGURE=no

At the beginning, I have this notification message , I don’t know what it means

sudo ./ BOARD=clockworkpi-a06 BRANCH=current BUILD_MINIMAL=no BUILD_DESKTOP=no BUILD_ONLY=u-boot,kernel,armbian-config,armbian-zsh,plymouth-theme-armbian,armbian-firmware,armbian-bsp KERNEL_CONFIGURE=no
[sudo] password for ubuntu:
[ o.k. ] This script will try to update
[ warn ] Can’t update since you made changes to:
Press or exit to abort compilation , to ignore and continue, diff to display changes

At a point , I have this error I can’t go any further

arch/arm64/boot/dts/rockchip/overlay/rockchip-spi-spidev.dts:22.11-27.6: Warning (spi_bus_reg): /fragment@1/overlay/spidev: SPI bus unit address format error, expected “0”
arch/arm64/boot/dts/rockchip/overlay/rockchip-spi-spidev.dts:36.11-41.6: Warning (spi_bus_reg): /fragment@2/overlay/spidev: SPI bus unit address format error, expected “0”
arch/arm64/boot/dts/rockchip/overlay/rockchip-spi-spidev.dts:50.11-55.6: Warning (spi_bus_reg): /fragment@3/overlay/spidev: SPI bus unit address format error, expected “0”
arch/arm64/boot/dts/rockchip/overlay/rockchip-spi-spidev.dts:64.11-69.6: Warning (spi_bus_reg): /fragment@4/overlay/spidev: SPI bus unit address format error, expected “0”
drivers/devfreq/event/rockchip-dfi.c:610:19: error: ‘rockchip_dfi_probe’ undeclared here (not in a function); did you mean ‘rockchip_dfi_driver’?
drivers/devfreq/event/rockchip-dfi.c:613:35: error: ‘rockchip_dfi_id_match’ undeclared here (not in a function); did you mean ‘rockchip_dfi_init’?
make[3]: *** [scripts/ drivers/devfreq/event/rockchip-dfi.o] Error 1
make[2]: *** [scripts/ drivers/devfreq/event] Error 2
make[1]: *** [scripts/ drivers/devfreq] Error 2
make: *** [Makefile:1907: drivers] Error 2
[ error ] ERROR in function compile_kernel [ functions/cli/ → functions/main/ → functions/main/ → functions/compilation/ → functions/logging/ ]
[ error ] Kernel was not built [ @host ]
[ o.k. ] Process terminated

So can someone help . I would like to do the same with Kali Linux

I retreive an armbian version of Kali and I can’t start any startx session

i’ve had the same issue, unsure of the cause. i’ll look into it again either soon or later today probably


patch rk3328-add-dmc-driver.patch to remove rockchip-dfi.c from it.


edit: custom A06 Armbian image successfully booted!


What is the file to modify ?



the one in rockchip64-5.15, as it corresponds to the kernel we’re building. remove the rockchip-dfi.c line at the top and the whole entry for the file

linux 6.5.0-1008-raspi aarch64 .
6.5 isn’t in the list

this is for A06, not raspi.

edit the file /home/ubuntu/build/patch/kernel/archive/rockchip64-5.15/rk3328-add-dmc-driver.patch like this:
remove the whole line containing “drivers/devfreq/event/rockchip-dfi.c”

then delete from line 637 to line 1291ish (cut-out the rockchip-dfi.c diff section essentially)