Let's play Shadow Warrior!


#1

Who wants some wang?

After a new Duke Nukem 3D tag for the GameShell, you can now try out Shadow Warrior!

And don’t worry. There will be Blood. :wink:


#2

you are the best thank you sooooo much!!!


#3

I’m running ClockworkOS v0.3. I installed the ShadowWarrior Classic files from Steam. When I launch this, I get a setup screen for a few seconds and then a blank grey screen. The only way out is to force my Gameshell to shutdown.


#4

Thanks for the feedback. Give me some time to reproduce this, so I can fix it.


#5

@RTK and @lasvegas. I could reproduce it by setting fbturbo to lima.

Settings --> GPU driver switch

Which GPU driver did you use when you started Shadow Warrior?


#6

i use lima because it fixed the screen tearing in my favorite games :smiley:


#7

so i switched to fbturbo have picture but says sound is corrupted even if i remove the files and re copy same thing was working before :smiley:


#8

nvm im a tool forgot to make them lowercase lol


#9

I tried launching it in both lima and fbturbo. Both result in the grey screen after the init screen. The sound is okay though.

BTW: I am using the new model logic board w/HDMI. Although I haven’t tried launching it on the HDMI display.


#10

I had to redo it but it worked just deleted the zip and shadow warrior and followed the same thing but launched it in fbturbo and it works really well now not really sure why. lol


#11

So, for everyone:

This release only works on fbturbo. I will try to make a new version that always works.


#12

Thank you for your hard work!


#13

Im confused… I followed the directions posted here and its working fine for me. I am using the Lima driver. Only issue I am having is with unbinding controls.


#14

The results indeed seem inconsistent among users. Needs some more investigation.

You can manually edit the game controls in a file the game made:

~/.jfsw/sw.cfg

You can delete this directory altogether if you want a clean new configuration.


#15

Perfect! Thanks again. Your posts are awesome.


#16

Great work! Gotta play Shadow Warrior again! :slight_smile:
Btw do you think it would be possible to get the old Strife (1996) working? :slight_smile:


#17

Strife is based on the Doom engine (id Tech 1). If I remember correctly chocolate-strife also exists. We would have to find out if this package is installable like the other chocolates (doom, heretic and hexen).

So… probably yes.


#18

I will have to try while i have some time (too much work :frowning:)
I was 10 when it came out in the 90’s and i wasn’t able (or didn’t have the patience :smiley:) to finish it unlike doom I & II, hexen and heretic, so i hope it will run so i can beat it finally :smiley: