Need help with Ps1 emulation

  1. I think that should be OS 0.5. Although, I’m not sure what happens these days if you try and update the launcher while on OS 0.4. Did you ever flash a new OS? Or did you ever do the OS 0.4-0.5 update script? If you didn’t, you’re possibly using 0.4, with a confused updated launcher that expects OS 0.5. A few things moved around with the 0.5 update.
    In short, you might want to try flashing a proper fresh 0.5 image.
    As for how to check, go into settings>about and look at what kernel version you have. If it’s 5.3.6 or 5.4.6, you’re on OS 0.5.
  2. If you’re new to computers, I’m guessing that means you haven’t tried to modify anything just yet.
    3 and 4… I probably should have phrased it better. Sorry! Where did you put the playstation image? And what does the playstation image look like?
  3. I was hoping you’d be able to open up that action.config file to double check its contents are correct. But give point 2., I doubt you would have tinkered with it.
  4. The dot before the .pcsx makes it a hidden file. I’ve never used filezilla, so don’t know how to get it to view hidden files, but I’m guessing you can choose something in the views menu? That said, just like point 2, I’m guessing you haven’t altered any of these files. That said, it would be good to confirm that they are there, and not in another location. OS 0.5 has them in /apps/emulators. OS 0.4 has them in /launcher/
    Doing an update would change the contents of the launcher directory to look like what is expected of OS 0.5, ie nothing. A stock 0.5 image has the .pcsx file in a different location that is not present on 0.4. If you had a half modified 0.4 image, this would essentially break PCSX.
    If you haven’t done too much with your gameshell, I’d strongly recommend formatting it with a fresh 0.5 image. But if you have done a lot, I can see what I can do with helping you restore your files, if that is indeed the cause. (Tomorrow that is. It’s 3am and I probably should be in bed!)

I reflashed to 0.5 and I get the clockwork screen but then it goes black?
Is this a common issue?
Do you know how to fix this?

This is possibly the file system expansion script. Just let it do its thing twice, rebooting. You’ll have all of the available disk space useable.
Also, I’m guessing you’re not talking about PS1 emulation here, and clockwork OS in general?

Sorry I have been inactive the last month, I have been very busy lately. However, i am ready to use the game shell again😀. I installed 0.5 deot and it looks great but I am having the same problem. I have decided to try another way instead of FileZilla to transfer ps1 Roms. Could some one on the forums show me the way to install roms via ssh/putty? Thank you so much, I am already using my gameshell so much again🤗

Ooh yay you installed my custom image! I’m guessing you installed the latest 200224 build? Don’t forget to run the file system expand script located in the utilities folder to use all the available space on your SD card. This image doesn’t automatically expand. Yet ;).
I’m glad you mentioned this, so I can reference the correct file directory structure.

You’ll need to type:

scp “source of the file on your computer” “destination of where you want to put the file”


scp game.iso cpi@

There are a bunch of other options you can add to the process. You don’t need to worry about them for the most part, just doing a file copy.
check this out

This is assuming you know how to connect to your gameshell via SSH. Hopefully you’ve gotten that. There are a few tutorials on how to do that in the forums.
ssh tutorial

That said, I have a feeling you’re having a problem with file format compatibility. Sending it via ssh would be no different to using a GUI like FileZilla, unless it’s configured incorrectly, or if windows hasn’t added it to its firewall exception list. I haven’t used windows in years, so can’t say how security etc behaves these days. Not have I ever used FileZilla. I used to use putty back when I used windows more than a decade ago.

Sometimes when you download an image, it might be in a compressed archive, like a *.zip file. You’ll need to decompress it. Sometimes it’s in a PSP eboot format, which will need to be converted first. If you can just take a screen shot of the file you’re trying to send, we’ll be able to identify if it’s compatible.

There’s something called an action.config file. It’s what tells the pcsx directory what kind of file extensions to show in its list. In a nutshell, your file type needs to be one that is referenced in this action.config file. You shouldn’t need to modify the action.config file, as it has the most common file types listed by default. You could possibly be using a game that isn’t a common format.

Finally, you might need a bios file. This needs to be in the correct format, and placed in the correct directory. We’ll cross that hurdle once we work out what game your using, and it’s exact file extension/format.

Have you gotten anything else to work on the Gameshell? Like, have you had any luck transferring any other console Roms? Just trying to gauge where you’re at.

Let me know how you go! :slight_smile: We will get PSX games working!

1 Like

Thank you so much for responding so quickly! My other roms for other consoles are all zip files and they work fine(haven’t tried N64 yet), but I will try decompressing the ps1 roms and see if that works. When I decompress the zip file should I get a .bin and .cue file? Will update tommorow or in a few hours. Thanks! :blush:

Only thing is that is that I don’t have volume controls


I’m glad it worked!
Re: volume control, If you’re using my custom image, then I have installed a global volume control mod. Just hold down shift and push the start and select buttons. (+/-)
There isn’t any verbose display showing it, but it will be adjusting it. There isn’t an inbuilt volume control in the PCSX standalone app.
If you’re using Retroarch, the volume controls are in there as well, and display what the volume level is.
Glad you could also enjoy the N64 too! That’s a bit of a pain to setup usually. Just be careful: the volume up and down buttons are also mapped to state save and load. Hmm I should probably change that!

1 Like

Once again thank you so much!!!
By the way, do I need the .cue files and how do I put the bios file in? I tried just dropping a SCPH1001.BIN in the BIOS folder but it didn’t work

The cue files are only needed if you want to use discs that have more than one data tracks. Usually that’s like, a separate track for CD audio etc. For the most part, I don’t really worry about it. They’re files that can be generated easily enough if you need them, and take up next to no space.

As for where to put your bios files, since I know you’re using my image, I can confirm that you will find the BIOS location for PCSX in ~/apps/emulators/.pcsx
As I mentioned in a post above, the .pcsx folder is set to hidden; denoted by the period preceding the directory name. If you’re using FileZilla, you will need to enable some setting to show hidden folders. I don’t use FileZilla, or Windows so I’m not sure how that would be done. Im assuming in View, it would be a “show hidden files” option.
After you’ve found the hidden directory, place your bios into the bios directory.
Note that any save data made with one bios will be incompatible with save data using another one.

1 Like

Thank you, I have enabled hidden files. Is this where I should put the bios file?image|375x500

I no!! Haha sorry my mistake. Only after seeing the image did I remember that the BIOS folder is actually in the same folder as the pcsx folder. So you actually got the BIOS folder correct to begin with!
After that you can select the bios in PCSX.
That said, the BIOS directory is indirectly determined by where the .pcsx directory is located.

On a side note, since you’re using my custom community image anyway, check the first post in the thread for instruction on where to put other files etc. it’s under the “post installation” section near the bottom.

1 Like

I think have put the bios file in the correct directoryimage but for some reason it still uses hle?

Looks like everything is right.
Try pushing left and right :slight_smile:

I now can see the change the from hle, but some games still don’t run, mgs just gets stuck in the booting up screen and the bios goes back to hle when I exit the game

1 Like

Mgs in particular you will need to reset the game once after loading it. After that, just use state saves to overcome having to do this in future. :slight_smile:

On the note of state saves, like I mentioned above, your saves will need to be done using the bios you want to use. If you made a state save using HLE, it will always load using the HLE bios. Just save the game normally, choose the bios you want, and load up as if you were playing a normal console to get past this. This could be why your bios switches back to HLE.

Also don’t forget to select the “save global config” option. Of course you can do it on a per game basis too.

1 Like

All is good now, you were extremely helpful

1 Like

No worries! Thanks for starting this thread. No doubt someone else will experience similar problems, and will be able to follow this. :slight_smile:

Also you should have volume controls. Hopefully that’s working for you!

Volume Controls are working!!!

1 Like

Same problem here. Trying to emulate homebrew games from this PS1 ROMset but can’t do anything since I am noob.If anyone can guide me and tell me which emulator I need to use for Windows 7 to play games I will be thankfull.

Thanks a lot. Just read your tips and they are more than helpful.

1 Like