clockworkpi

RetroArch Megathread

sure thing…

so you just want to run this command:

bash <(curl -s https://raw.githubusercontent.com/hpcodecraft/Gameshell/master/retroarch/setup.sh)

that will download a setup script for you.

after that, you may have to set executable permissions on that file. to do that, use this command:

sudo chmod +x setup.sh

once that is done, you can run the setup script like so:

./setup.sh

then the thing should just run and uhhhh you’ll be good to go. could take a while to compile everything. iirc i had to leave mine download/compiling for 15 minutes… maybe more?

1 Like

Great, thanks so much! I’ll try it as soon as I can!

Just noticed the website sends a 404, I’ll look for a mirror

It does? Let me know if you need me to grab a backup from my gameshell.

Hi to all,
please allow me a total noop question.
I have tried to follow your guide.

  1. i opend the ssh connection to my GH -> works fine
  2. the command: sudo apt-get install git build-essential -> works fine
  3. the command: sudo apt-get build-dep retroarch -> works fine
  4. git clone https://github.com/libretro/RetroArch.git retroarch -> i dont have seen any error messages, so i think -> woks fine
  5. the command: cd retroarch -> No such file or directory
    do you know what i have done wrong?
    And Retroarch is now gone from my Start Menu and even when i browse all dirs via FTP i dont have a Retroarch dir… :frowning:
    Thank you for your Help :slight_smile:

Several times later i found out it works,
but each time GS freezes at line : CXX deps/SPIRV-Cross/spirv_parser.cpp
rally, each time…
i have already burned several cards…
Any ideas regarding these error messages…?

Did all the step and retroarch just crashes. :frowning:

im trying to setup a fresh install of 0.21 and some weird things are happening when I start to build the environment. never occurred before. is it outdated? am I forced to use 0.4 now?

Figured it out. Good to go on 0.21 with RA 1.7.8

cant get XMB working at all, keeps reverting to the defauly setup, but I can change the color pallete…

What was the issue? I cant get 1.7.8 to load at all, but 1.7.7 works without issue

After building, I had to SSH in and open ./config/retroarch/config.txt (whatever the config file is called I’m being speedy)

Change video_driver from “sdl2” to “gl” it should load up

Hullo! Welcome to the forums. :))

By default it installs it into the root of your home directory. All of the shortcuts in the launcher refer to it being in the .config directory.

Either change all of your emulator’s paths to the newly installed retroarch, or move the newly installed retroarch to .config, replacing the old version.

Is 1.7.8 better then 1.7.7? Maybe aspect ratio issue had been fixed/gone somehow? Or something else changed besides new features?

Well, doing a fresh install of any version will give you a few more perks. Control input problems seem to be fixed. As does actually being able to change the graphics driver to GL instead of just SDL2. Mine seems to take a tad longer to load, but that could just be because I’ve enabled too much junk.

The AI Feature looks interesting. Ie hitting a key go send a screen shot of the game to an external server, and having it identify the tech on the screen and return a super imposed screen shot back, translated to whatever language you have set. It would be great for import games!

So I guess it has more “stuff” but whether it’s better or not probably depends on whether you use retroarch, or just standalone. I actually prefer retroarch over standalone due to unified features Etc. I am also probably in the minority.

XMB needs extra assets that aren’t installed by default. If you just do a full fresh install/update you’ll get everything. The script for updating listed above works well.

It runs, but boy is the resolution going to need go be tiny!! It’s also a tad “chuggy”
image|666x500

Ok, I tried to update with method from first post but it doesn’t work. Could someone update tutorial?

ok tried that and got the 404 error, has it been updated yet?

Could you post a picture of what the 404 error looks like?

@podmaz - if you’re having trouble blue you could use HPcodecraft’s script. Same one people use for expanding their file system. There is an option to update retroarch.

Technically it’s installing it completely from scratch; fresh. It will be installed along side 1.7.7.

That said, the included 1.7.7 is a slimmed down version with unnecessary assets omitted, since they run suboptimally. Likewise, some unused instructions that aren’t compatible won’t be there anyway.

didnt get a picture, was a 404 error, usually means the page cant be found