RetroArch Megathread

Give me a few, I’ll give it a shot

try adding --disable-opengl_core to the configure line

Configure like this:

./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --disable-discord --disable-langextra --enable-mali_fbdev --enable-opengles --disable-opengl_core --disable-opengl1
1 Like

Why not have a video tutorial

Video tutorials are a waste of time.
You have to pause, copy stuff from video description, etc.

Also, it would take me a couple hours to make a decent video, I’d rather offload that onto the readers :stuck_out_tongue:


Or maybe a repo with precompiled stuff, why waste electricity? and be part of the global warming? :stuck_out_tongue:

if this was something that was done up and maybed added to the repository (see other threads) it would be quite useful.

I followed the guide and was able to configure retroarch with no issues. However, when I try to run any games from an emulator it boots back to the launcher menu. I have used a few different versions of snes9x for SNES and tried mGBA, Meteor and gpSP for GBA. I also tried changing the GPU driver to Lima. Any help would be much appreciated!

1 Like

after i run this line it tells me that there are 3 apts that need to be upgraded
“0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.” so i enter sudo apt upgrade, but then it tells me that i can’t do that “Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?” and i try that, i type in “apt-get update”, the result is " Failed to process build dependencies". I just noticed as i’m writing this that retroarch is already installed, so now my question is what is the deal with these 3 apts?

when i enter make -j4 i get this:

Makefile:10: No such file or directory is outdated or non-existing. Run ./configure again.
Makefile:190: recipe for target ‘’ failed
make: *** [] Error 1

I have this exact same problem. The emulators in Retro Games work fine, and Retroarch loads cores without a problem, but loading games causes a short loading screen, a less-than-a-second black screen, another loading screen for a few seconds, and back to launcher. I’ve tried games zipped and unzipped. I’ve tried every core I have games for. I followed the setup instructions verbatim, and even tried a new memory card. Nothing works. I have 1.7.7 - perhaps an older version of RA works better on ClockworkPi?

[EDIT] Welp, now almost no emulators work. The MGBA, Nestopia, and MAME options in the Retro Games folder all load games, but they all have the screen freeze around 30 seconds after starting - I can still hear sound, but the only thing I can do to get out of it is power down the unit. Changing the GPU driver had no effect. So, now the only working emulator I have is Pcsx. I tried using the gPSP core available in another topic, no change. I think all three of these use Retroarch as a launcher, so I’m betting that’s the culprit, but I have no idea how to fix it. I followed the setup instructions exactly, so maybe I have a bad Clockwork Pi?

[EDIT 2] I attempted to rebuild Retroarch, and got an error that EGL was disabled. This didn’t happen the first time. I added --enable-egl to the list of commands in the .configure, and it installed okay, but nothing has changed. I still cannot load games in Retroarch, and attempting to run them through the emulators in the Retro Games folder results in a frozen screen after a few seconds.

1 Like

you have to run the configure script before running make

Hi, thanks so much for the thorough guide!
I have some dumb questions to ask. I’ll ask the first and then go from there.

  1. So these instructions are to replace the current RetroArch that comes preinstalled on the GS (I received mine May 2019)? Or were these instructions to put RetroArch on an early version of GS that did not come with it?

I ask because I’m not sure whether I should start with the apt-get and git clone commands. Thansk!

your gs just have one of the official os image, so the retroarch included is not dated from your purchase but from the os release date, and that’s not mean retroarch included in the os was the latest available from this date.

the git repo contain the official current source code of retroarch
it’s a pretty active project and @fr500 is one of the top author
just use his tutorial, buy him a beer and enjoy \o/

Perfect, makes total sense! Thanks so much!!

“Now edit your config and change the video_filter_dir too
video_filter_dir = “~/.config/retroarch/filters/video/””

Sorry but I’m not sure how to do this? Specifically the “edit your config and change…etc.”

config file is at ~/.config/retroarch/retroarch.cfg
(in linux ~ mean your home folder /home/cpi/
also file & folder starting with a dot are hidden)
to edit the file you could made it by ssh using vim by exemple
vim ~/.config/retroarch/retroarch.cfg
type /video_filter_dir and enter to find string video_filter_dir
type i to enter insert mode
do your edition (paste can be do using ctrl + shift + v)
escape key will exit edit mode
type :wq and enter to write file and quit vim

1 Like

Thanks so much, worked perfectly!!

I’ve made the directories as indicated above in the tutorial and changed the directory settings but when I save a game (specifically a GBA game) it still appears in /home/cpi/games/MGBA. When looking at the config file is still says “savestates_in_content_dir = “true””. The same is true for save files.

I’m assuming that I need to change this to “false” and then the saved games will then start heading to the directories I’ve made?

yes, the bools are prevalents over the defined paths

1 Like


In the above it looks like the BIOS/system directory is in /home/cpi/games/Retroarch. However, I don’t have a Retroarch folder in my games folder and the setup given seems similar.

I’m assuming the below quote has the answer but I’m not sure why, help please?