RetroArch Megathread

You’re misreading it, that’s how I setup things myself.
Yes you have to turn off those bools so it saves in your folders.

Oh I see, that makes sense. Thanks!!

I posted this elsewhere but the thread has been inactive for a while

Thanks for the detailed instructions, very helpful!

I have a noob question. What is in the newly created BIOS folder? The original directory for System/BIOS in Retroarch before doing any of FR500’s instructions was ~/apps/emulators which has the following files.

cpi@clockworkpi:~/apps/emulators$ ls -a

I’m not sure what creating a new folder and directing Retroarch System/BIOS towards that new (and presumably empty folder) actually does. What am I missing?

1 Like

I just did a clean install and am now running RA 1.7.7.
I’ve noticed that my PCSX emulator has taken a small hit in performance. Is there another .so floating around I’m not aware of

1 Like


Hello everyone.

So I used this to update RA + some other stuff: How can I Retroarch 1.7.0 to 1.7.3?

However, now RA, as well as other games such as NyanCat, ask for a login like so:

How do I fix this? There is no way to input the login info with the keypad, so it’s stuck there until I power off the GameShell.

Same thing was discussed here: seems to be a problem with the RA config.

I solved it by putting a backup of my modified config on my GS.

Hey, just to let you know, I’m unsuscribing. I’m no longer involved with RetroArch.
I wish you all the best.

Have fun!

So, there is no one from the Retroarch team looking at the GameShell version now?

Retroarch is the only reason I bought one, what a letdown :frowning:

It is a normal version for the hardware used and not specific for Gameshell so it will keep on being updated. We have only lost our go to guy who could help us test/fix things :wink:

Do you know why only 20% of the time games start for me and on the other 80% I need to ssh to the GS and reboot it because it crashes? it’s been like this since the 0.3 update came out with the new lima driver.

I was hoping a potential 0.4 version of the OS could fix this but the devs seem to be missing :face_with_raised_eyebrow:

So I’m new to everything, but I followed this guide and now when I use go to run a ROM via MGBA through RA it takes me to the clockworkpi menu. When I go through the shortcut on that menu, the game freezes as it loads. Any thoughts on what I’m doing wrong?

In 0.3 the lima driver is quite unstable (see other forum threads). If you switch it to the regular driver (not being lima), instability should decrease significantly and cpu usage should be lower and battery will last longer.

for clockwork pi it says my GPU driver is Fbturbo already. I’m using 1.24 i think if that helps. Like I said, I’m really new to this, so I’ll do my best to give any info needed to help.

Hey has anyone built this recently?

I’ve tried running the commands in the OP, but it has stalled each time it gets to “CXX deps/SPRIV-Cross/spirv_parser.cpp”

I’ve tried deleting the git folder and doing the steps over, but no luck. Same with rebooting and running them.

When I say “stalled”, it’s sat for an hour at that step without moving. Am I just being impatient, or does anyone have any other suggestions?


Edit: is it possible for someone to share a compiled build…?

Edit: This worked – bash <(curl -s

Edit 3: Retroarch compiled using that script but now when I try to access it in the launcher it asks for a clockwork pi login and password.

Maybe I just need to chmod the file?

Edit 4: the solution here of replacing the cfg worked: RetroArch Asking for Login?

You should execute this command on your gameshell through ssh (using tiny cloud)

Please help I messed upmy Key bindings

You should be able to go to the GameShell Settings and set your keybindings there, pressing X to apply them to RetroArch.

However, I’m having an issue in RetroArch where I can’t remap input for PCSX Rearmed…Anyone know why it won’t even allow me to edit them?

hi this is my first time with gameshell and I hardly know anything, just want play some retro games

1 Like

thanks for your info, however i need more help in figuring out how to load new games and roms

1 Like