RetroArch Megathread

retroarch
howto

#82

Everyone:

Please try the cores here:

http://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest
core_updater_buildbot_url = "http://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest"

If possible compare them to the others and let me know what’s better, what’s worse, what’s broken.
I’ll try to fix the ones not building in due time.

Don’t have too much time to test myself right now.


#83

PSX : mednafen_psx_libretro.so don’t work (retroarch can’t open core), your pcsx_rearmed_libretro.so work better

MEGADRIVE : genesis_plus_gx_libretro.so work but a little lag, picodrive_libretro.so work very good

SNES : i use catsfc_libretro.so and it work fine, i have not test snes9x

GBA : gpsp_libretro.so and mgba_libretro.so seem work fine

MAME : your mame2003_plus_libretro.so work very good

thank for your work :slight_smile:


#84

When I enter “Make -j4” putty stalls out on “CXX deps/glslang/glslang.cpp”. Any thoughts? Ran all commands recommended previous to this except for —disable-v412 which would not cooperate.

I have no idea what I’m doing, btw. First Linux experience. My gameshell doesn’t respond to commands at the moment either.


#85

Going to hard reboot the gameshell and start over. Here’s hoping I didn’t break it!


#86

It’s not likely broken, but I don’t know why that is building. Are you sure you did --disable-vulkan on configure?


#87

Pretty sure but will double check on my next stab at it. Only one the system pushed back on was disable v412


#88

it’s v4l2 (lowercase L not 1)


#89

@fr500 hi, Thx for this tutorial.
I have a problem, I’ve done what was explained at the beginning (git, make, install) and everything was OK. But now when I try to start Retroarch from the menu I get “loading” then a black screen and back to the menu.
What’s wrong? Thx for your help!


#90

only the dosbox_svn_libretro.so from the link above can work on GS
I also downloaded other versions of dosbox_svn_libretro.so from libretro.com,but none of them worked, all segment fault

Will this .so be on libretro.com ?


#91

Hey folks,

thank you for this nice tutorial :slight_smile: It helped a lot. Allthough I encounter some strange problems… First, it seems that my wifi connection is pretty unstable (I guess), because it sometimes won’t update the core list, and if it’s updated, I can’t download cores. It sometimes works, but I need up to 10 retries…

Anyway, I downloaded a core and transfered it to the folder, where my cores are located. I don’t know if this worked or not since I tried to download it via the GameSH itself and it failed, but it was listed after the failed attempt.

When I try to select the core, I just got thrown to the main menu without any error message or something, but it still says no core selected…

Any Idea why this happens? Is this core incompatible?

Thanks in advance!

P.S: It’s the MAME_libretro core.(not mame2003 or something)


#92

Looks like I’m not using the latest version of retroarch. Is there a simple way to update it via SSH or do I have to download the whole thing and proceed with this install listed here like it was new?


#93

@Oldric try restoring the cfg and starting over I guess, haven’t seen that

@guu yes once I figure buildbot build errors

@Kenny_Ken I can’t really help you with your wifi sorry

@Rene_Rosa I will probably offer debian packages later, but for now this is it. It’s an educational console so I don’t see anything wrong with teaching people about how software is built


#94

Added video filters addendum


#95

anybody can open mednafen_psx_libretro core ?


#97

I’ve created a bash script to automate the whole setup described in this thread so far by @fr500, including the volume input fix of @Oxydium.

To use it, SSH into your Gameshell and enter this command:

bash <(curl -s https://raw.githubusercontent.com/hpcodecraft/Gameshell/master/retroarch/setup.sh)

The script itself and the retroarch.cfg it will download can be found here: https://github.com/hpcodecraft/Gameshell

Enjoy and please let me know if I missed something, it was put together quite quickly.

Edit: config file now includes updated core_updater_buildbot_url


#98

The WiFi seems a bit weak/unstable in general at the moment. For me it works only in one room of my flat - I’ve seen others post about problems here, too. So for that part -> sit next to your router :grin:


#99

Just get an android phone, download andftp then tether to your GS and computer. That’s what I’m doing, you don’t even need internet.


#100

It doesn’t work and if it did it would probably be too slow for ARM


#101

I finally got everything to work! Had to re-flash the OS to my newly formatted card, and then follow all the steps in this article again, but I got it!

Now another problem though. I seem to have about a half second lag on any game that I load. I tuned everything like you have it, but everything still lags. Even Cavestory on the Main Menu lags. Any ideas?

EDIT: Fixed. Just had to lower my Audio Latency to 120ms.


#102

Hi,
Great tutorial. It worked as a charm for everything except FBA or MAME.
Every time I launch the .zip file, it goes back to the launcher homepage.
Would you have an idea?
Thanks
Charly

[EDIT] It works now. I changed the core to fbalpha_libretro.so and it seems to be ok. I tried 4 different games without any issues, except that sometimes the screen glitches for a few seconds when the game loads itself.
Thanks.
C