RetroArch Megathread

retroarch
howto

#62

When github ask for a password on HTTPS URL it is generally because the URL is not valid, but I can’t see anything wrong there :confused:


#63

@ESH72882, you’ve typed liberto instead of libretro in the github url. It should be:

https://github.com/ libretro /RetroArch.git

Hope this helps! :smile:


#64

I made the same mistake, and now the way I remember it is that RetroArch helps you build a library of retro games, so it’s lib + retro. Before I was thinking it had to do with “free games” (liberty->liberto) and that messed me up too.


#65

Well spotted! :smiley:


#66

@fr500 I was unable to clear the Hotkey Binds with the Y key. Is there a step that is missing? Mine kept trying to do a search.

Any thoughts?


#67

Hi Guys, thanks for your amazing thread.

I have a little problem here when i try to find gPSP core or PCSX-ReARMed core in the online updater, they are not available
I can only find Remote Joy and Beetle PSX
Am I the only one with that issue ?
I find the link to donwload them on my computer but I stil don’t get It to install them without the online updater.
I should be able to install them via ssh but… I’m kind of a noob here sorry.
Can someone explain how to do that please ?


#68

Save them in ~/.config/retroarch/cores/ and restart your GS.


#69

OK thanks. I just find the way to do that… via SFTP with FileZilla
via the IP Adress wrote in tiny Cloud and the username/password cpi.
Thanks a lot I was only missing the folder path now and you gave it to me <3


#70

Not really sure, I reviewed the process and it works, maybe read the notes regarding how I installed the buttons (ie: I installed my buttons following SNES layout, not XBOX 360 layout)


#71

Thanks for the clue. That was really messing me up. However, I am now having trouble with another part of the instructions.
./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --dismake -j4

I am pretty sure that I typed this one in to the command line correctly, but it tells me that I have typed an unknown option. Is this supposed to happen? Or did I make another mistake in the coding?

I have included a picture of this to help explain.


#72

lol?

it’s two different commands

make -j4 is after configure runs


#73

make -j4 is a separate command to the ./configure stuff, and you have some stuff missing from configure too. There should be two commands:

  1. ./configure --disable-vulkan --disable-ffmpeg --enable-xmb --disable-materialui --disable-flac --disable-parport --disable-vulkan_display --disable-videocore --disable-videoprocessor --disable-v4l2 --enable-x11 --disable-wayland --disable-vg --disable-jack --enable-kms

  2. make -j4


#74

And then you run this after those two.


#75

@fr500 and @eashwar

Thank you so much for helping out with the coding problems. I cannot believe I made the mistake of ignoring the slide bar at the top with the full ./configure command line. However, now that I have gotten through all of the coding, I am now stuck when it comes to setting up the directories in RetroArch. I apologize for all of the trouble, most of my experience is with retropie and not with retroarch, and I have usually had tutorial videos to follow along with. So all of your help is appreciated.

My problem with the directories is that I get to the system bios directory and I can find:
/home/cpi/games
but I cannot find retroarch. saves , states, or system for any of the recommendations. I have included a pic for reference to what I am saying.


#76

These directories don’t exist on the GameShell - what FR was recommending is that you create these folders so that you can configure RetroArch to use them. (you can use the mkdir command to make folders).

Hope this helps!

Eash


#77

Ok so, new thing
You can try new cores optimized for armv7 neon (rpi, cpi and others)

core_updater_buildbot_url = "http://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest"

I haven’t tried them but this should be the correct URL going forward.
So hopefully picodrive, gpsp, dosbox and pcsx_rearmed should be as fast as the ones I built manually


#78

gPSP seems fine, pcsx doesn’t build, trying to fix picodrive atm (should be fullspeed once I’m done)


#79

How can I uninstall Retroarch ?


#80

hi Darius thanks for this tutorial.

Today appear a new official update, so after, what stay of your upgrade ? :blush:


#81

I tried your settings but they didn’t work.
I think you meant setting input_volume_down and input_volume_up.

As @fr500 said, you can set them directly in Settings > Input > Input Hotkey Binds.
Thank for the guide @fr500, it was a great help to start using Retroarch.