RetroArch Megathread

retroarch
howto

#124

There is, the keypad is a keyboard. You can change the .ino or use the headers and add more buttons.

Edit: Identifies itself as a HID device to the mainboard.


#125

So as is, there isn’t one, you can’t hookup one off the shelf (not via BT or USB-OTH)
So there isn’t one

@Fuseps, FBA is a better bet, it’s a better integrated core than MAME is (you can change controls without re-binding)


#126

Hey guys, i have this issue, what can i do here?


#128

Well

First of all apt is with build-dep not build.
The second command failed due to a TLS packet, just try again I guess, means it failed to receive something


#129

Hey, it says no such file or directory for cd gfx/video_filters


#130

mkdir -p gfx/video_filters

LasVegas


#131

Thanks @lasvegas, however it says “too many arguments”


#132

Did you try it with ‘sudo’?

sudo mkdir -p gfx/video_filters

LasVegas


#133

No, it doesn’t work either


#134

Hi Oxidium, i cannot find the .config on WinSCP, i seems is a hide folder, how can i look at it? or how can i put those archives in ~/.config/retroarch/cores/ ?


#135

Honestly, that looks like it did work. Entering ls should show the gfx directory and ls gfx should show the video_filters directory.

LasVegas


#136

Heh you’re doing it wrong:

So from the RetroArch repo do:

cd gfx/video_filters
make
mkdir -p ~/.config/retroarch/filters/
cp *.filt *.so ~/.config/retroarch/filters/video

So from the RetroArch repo do: <--------------This part is important, you cloned Retroarch in the first steps

git clone https://github.com/libretro/RetroArch.git retroarch

So assuming you did this in your home dir

cd retroarch
cd gfx/video_filters
etc

#137

Hello,
Great tutorial!

However, I got stucked after I run the “make -j4” command.
I got this:

tObjectEv]+0x142): undefined reference to `operator new(unsigned int)’
collect2: error: ld returned 1 exit status
Makefile:187: recipe for target ‘retroarch’ failed
make: *** [retroarch] Error 1

Any ideas??


#138

Hmmm, try adding --disable-discord to the configure flags.


#139

Getting the error shown in image after sudo make install


#140

I just

sudo make

it, and have the binary output somewhere and call it with scripts.


#141

Thanks a lot!
It updated perfectly and now I am running RetroArch 1.7.3.


#142

add --disable-discord to the configure flags, guess I’ll add that to the instructions, it’s something new.


#143

That also worked for me to be able to compile from the current master. without that flag it only worked on the last release tag.


#144

How to go back in retroarch? which key? Also I am not able to clear the input hotkey binds by pressing Y

And about installing the cores. The file that you have provided where do we put those like “pcsx_rearmed_liberto.so”?

I am sorry if I am asking too many questions I am trying to learn as much as I can.!

I have setup the buttons on the gameshell as shown in the picture