clockworkpi

Shows Invalid sign for Running N64 Roms

Okay. Just putting this here while I’m on lunch break. Basically putting in comments to say what each step does. Try running each of them individually, and report back on what the output is, if any present an error. We can work it out from there.

#DOWNLOAD AND INSTALLATION OF DEPENDENCIES AND BINARY
wget -O /home/cpi/mupen.sh https://www.dropbox.com/s/uxerntgv8kpluzm/mupen.sh?dl=1 && chmod +x /home/cpi/mupen.sh && ./mupen.sh

#CLEANUP OF INSTALLATION FILES
sudo rm /home/cpi/mupen.sh
sudo rm -r /home/cpi/mupen/

#OVERWRITE EXISTING MENU ITEM
wget -O -rf /home/cpi/apps/Menu/20_Retro\ Games/mupen64plus/action.config https://www.dropbox.com/s/932qp0yqjeta8ot/action.config?dl=1

#MAKE CONFIG DIRECTORY AND INSTALL OPTIMAL CONFIGURATION
mkdir /home/cpi/.config/mupen64plus/ && wget -O -rf /home/cpi/.config/mupen64plus/mupen64plus.cfg https://www.dropbox.com/s/9msh8d8js2tek9k/mupen64plus.cfg?dl=1

Wait. Did you copy each line, one at a time into your SSH session window, or just copy the whole lot, and pasted it in? That could be the problem, if at any stage one off the steps halted.

ok so I had to reset everything thats in it. so I’m gonna go from step 1 and do everything piece by piece because it froze and nothing was loading at all not even the menu.

ok the line that ended up not working and had an error on was this one Screen Shot 2020-03-18 at 1.12.15 PM

says it does not exist or has a directory, these are the ones that I have done

these 3 were successful

this one was the unsuccessful one

*#CLEANUP OF INSTALLATION FILES
sudo rm /home/cpi/mupen.sh
sudo rm -r /home/cpi/mupen/

Righto, so in response to:

Try running that part of the script without the mkdir (make directory) part.

Ie,

Cleanup honestly doesn’t matter, or need to be done. I’m just extremely OCD and can’t live with stray files, and feel extreme guilt giving people scripts that leave junk behind that may or may not ever get removed.

But the biggest question in keep coming back to:

Are you having trouble navigating to this directory?

1 Like

honestly yes lol I kinda have a hard time to navigate to the usr/local/bin folder to see if mupen64plus
im gonna try the home/cpi/apps/emulators

Ok so update on looking for the file it is there

Right. So looks like the script ran fine and installed everything. But just to be sure, can you also check the contents of /usr/local/lib/mupen64plus/
This is to confirm if all the lib files exist, and the script finished. You can also type cd /usr/local/lib/mupen64plus/ to navigate to this directory from terminal, then type ls to list what is inside the directory.

Also check to see if your action.config is in

/home/cpi/apps/Menu/20_Retro\ Games/80__mupen64+/action.config

Since you’re using DinguxCommander, navigate here to view the file, and tell me what you see.
This is the file that tells your gameshell to open the mupen64plus binary from the location in the first paragraph, apply the needed parameters and load a rom.

Finally, check that you have a config file for mupen64plus+ in /home/cpi/.config/mupen64plus/
That has all the settings for mupen64plus configured to run quickly.

The fact that you have mupen64plus in the local bin directory means that it should work. You shouldn’t need to have a copy of this in the /home/cpi/apps/emulators directory. If you did want to try having one there though, you’ll need to edit your action.config file to tell it to look there. Let’s just confirm you’ve even got an action.config for mupen64plus.

At this stage, unless you’ve got a lot installed, I think it would seriously be worth formatting your card, and starting from scratch. I think you might have run the scripts where I was telling the previous person how to undo the typo I made. I have since removed if from the initial post. Can you let me know if that’s what you’ve done?

If you do format and start from scratch, just run this ONLY, doing each line. Let me know the output in terminal if it has any errors.

In all seriousness though, it will be easier and less time consuming if you just installed my custom community image with mupen64plus pre installed, along with a whole bunch of other useful things updated. This includes an updated kernel and an option to do a safe overclock which will allow mupen64plus fo run faster. I made the image to help people get started, especially for mupen64plus, which presented itself as the most problematic thing to install for people.

N64 is one of the hardest things to emulate well on any system. For this reason don’t expect absolute miracles on the gameshell. Some games work. Some don’t. Some run well, and some are playable but look terrible. I just don’t want you to spend so much time troubleshooting like this, only fo be disappointed. I’m going through the process of showing you how to troubleshoot, since I believe the gameshell is an educational device that can teach you how fo use Linux. Hopefully you’re also learning a few things from this.

sir I will do this immediately! I will use the new custom image that you have made and if you have success I shall do this immediately! I actually have learned quite a bit in this time period I might wanna start to make my own custom interface and practicing more coding for the linux thanks a ton

1 Like

Hopefully it all gets sorted! There’s certainly a satisfaction of getting something working yourself, but there can be so many factors that contribute to what went wrong.
The best way to learn is to know what each command you’re typing actually does, and not just blindly copy pasting code in. At least that’s how I try and format things when I try and offer help.
Let me know how you go! :slight_smile:

The update works wonders and yes it was good to learn and know about coding or just new skills in general now I do have a question and I did read it on your custom image file . I have 2 new micro usb cards that are freshly formatted, with this update will it automatically auto expand or I got to do some other stuff to it

1 Like

Yup! Regarding build 200318 and 200319,

Supposedly, the auto expand doesn’t work on 400GB cards properly. I don’t know the specifics of it. Nor can I afford a 400GB SD card to test. So yeah, if it doesn’t expand properly, either run the expand utility I provided in the utils folder, or use the 200318 build, and use the expand utility.

Oh oh no it’s not that big (even though I’m crazy surprised they have sd cards that big) it’s a 64-128 SD card

All good. I’ve tested 16, 32, 64 and 128 cards.
Don’t forget to try an overclock/kernel change to see how different games perform on mupen64plus.

For your reference, you can’t change the settings via a menu. You’ll need go edit a config file located in

/home/cpi/.config/mupen64plus/mupen64plus.config

The .config file is a hidden one, so you’ll need to either just type the path, or if you’re using a GUI, enable hidden files. As for what the settings do/mean; try looking them up. They’re generic terms used for a lot of graphic options in different engines. Once you learn them in one, you’ve basically learned the keywords for them all, and the effect they have on processing loads.

I personally use “CyberDuck” on my Mac to visually access my gameshell, but that’s just because it’s what I used 20 years ago or so. There probably are better options. I’ve just never had problems with CyberDuck.

The controls for N64 are currently set to one that favours not using the LightKey attachment. AB = AB, XY = ZR, Start = Start, Select = L, Shift+ABXY = C(UDLR), Menu = Turbo, Shift+Menu = Quit, Shift + Select = State load, Shift + Start = State Load.

1 Like

Ok one of the micro sd worked wonders now this one is acting funny or giving me some visual weirdness, do I need to reflash it? It keeps flashing up and down

VERY INTERESTING! Someone else was having this exact problem!
I have no idea, but it could be to do with the SD card used? Could you let me know what kind of SD card, ie brand, size etc? It would be good to document. Also try using the image you didn’t use, I’d 200318 or 200319

I have the same problem. I’ve tried 200318 and 200319 for Sandisk 64G U1 2 pics and U3 1 pic. The screen flash up and down all the time……it’s make me insane.

could you try arch linux port to see if this problem occur too ?

sure I am using a 128 gb micro sd card

If you can provide the brand, speed, type (eg, A1, A2, XC1, how much use it’s had, method of writing the image etc.
If it runs, for now try using an alternative Kernel. It’s in the Utils folder.

Try also running the manual file expansion script.

Try flashing it again perhaps. Also try flashing a stock image on it. It’s funny; the stock image was the one having problems on larger SD cards.

So just confirming: it’s working on one SD card, but not the other? If you can provide info on the one that works, that would be great.

OK Sandisk 64G A1 , 64G XC1. Use Rufus and Win32Diskimager to wriitter the image. These 3 micro-sd cards I had ues them maybe for 1 year. I try reflash maybe 3 or 4 times for each micro-sd card.