clockworkpi

SNES Emulator Doesn't work for me

I searched all the threads for help with this but I can’t seem to find a solution to my problem. Most of the advice I see is a year old.

So I tried to loads games in the SFC9X and PocketSNES+ folders using FileZilla but none of the games I add work for either emulator. The games are not zipped and work fine on my other Retro handheld devices. I even use the emulator PocketSnes on my RG350 and the games work perfectly.

Any help would be great

Thanks

Hello and welcome to the forums!
Are you using a freshly installed OS? If you are, possibly try updating via the settings menu. This will change some files in the launcher, and possibly update expected directories for Roms etc.

There could be an indiscrepancy in the rom, emulator, core directories, relative to what the action.config file is expecting.

Also, was just the Roms you wanted transferred? There may have been more directories that overwrote some other things if you did a mass move. Also, files may not have fully transferred. I don’t use FileZilla, despite lots of other people using it. I believe some people have had problems with it in the past, especially with running script. If you’re on windows, I’m afraid I can’t offer any other alternatives since I haven’t used windows for over 15 years.

First thing‘s first. Do you have something called “warehouse” on your launcher’s home screen? If you do, you have the latest clockwork os 0.5 image, in which case you should update the launcher via settings.

If you don’t, I highly recommend you download a newer OS before trying to waste too much time on tinkering with something you will inevitably need to format anyway. It’s just better in practically every way, and will be more current, thus allowing you to follow instructions on the forums easier. Ie no more out of date thread contents.

That leads to the next question. Has anything else ever worked for you? I know that some of the emulators automatically get downloaded the first time they’re run. Before doing the aforementioned launcher patch, the SO URL in the action.config file of each emulator pointed to the wrong buildbot URL, if using Retroarch.

Try going into settings, and deleting the Retroarch cores (from within the launcher), update the launcher (Which should fix the URL), then attempt to run the emulators again; thus downloading the correct one.

If you can access the files of your gameshell via SSH, ensure that pocketSNES is in the ~/apps/emulators directory. Also check what the contents of the action.config file says.

Finally, if after all that it still isn’t working, I guess, try out my custom image. I’m not just spruking my own build, and I’d prefer to help people solve problems if at all possible. It’s just, I know how that image is set up completely, and therefore can pinpoint exactly what other problem may exist.