clockworkpi

Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

Hello, I’d like to ask you to prompt me “it seems that this is not a bootable image” when I use etcher to create an image by operating the deot_v1 + 191122.img.tar.bz2. The image does not seem to contain partition tables and may not be recognized or booted by the device "My English is not very good. I am a Chinese.

Hullo! Welcome to the forums.
You will need to decompress the *.bz2 first.

What operating system are you using? If you’re on a Mac, the built in archiving utility should be able to do the trick. Linux, it would depend on what packages you have installed. I’m haven’t used windows in far too long to be able to comment on how to do it, but I would assume it would work fairly painlessly, with say winrar or a similar program.

After you have decompressed it (it will take a while), you will have a slightly larger *.img file that you can use to write to your SD card.

Let us know how you go. :slight_smile:

Thank you very much for your reply. The day before yesterday, I entered “deot? V1 + 191111. Img. GZ”. On this basis, did I enter “deot? V1 + 191122. Img. GZ”? In addition, how to enter the back desktop of the simulator? I press the menu key, and the menu of the simulator comes out.

The 191111 image isn’t the same as the 191122 one. The latter has the more recent advances to the graphics drivers. There are two different downloads. Here’s a post with a few download links:

If you’re talking about Retroarch, try pushing shift and menu TWICE. It’s what I have set it to do, to avoid accidentally exiting when accidentally pushing menu once.

I think that’s what you’re asking?

Side note: the DEOT edition Gameshell are up for sale!

Thank you. It has been successful. Thank you for your modification and look forward to the next version.

1 Like

lima for gameshell os v0.4

https://mega.nz/#!VRUEnCyK!JFio9XTgJgExWucTP7bMGbKaANn1FQj2JijSymtHO6A

lima_v0.4_2.bin

https://mega.nz/#!IMdmjCbQ!5xAKF6YQgsRDVzdR2RZPoal8ydRN-sgMKvDonGVne-8
lima_v0.4_20191223_2.tar.gz

b4324f4a058579b00c16876d2c0a22fd lima_v0.4_2.bin
403e787e5f7783d5dca2cc407950f54d lima_v0.4_20191223_2.tar.gz

lima_v0.4.bin is just a self-extract binary for lima_v0.4_20191223.tar.gz

for people in china,download the lima_v0.4_20191223.tar.gz ,uncompress it, then replace the system source.list with:

sudo cp -f .sources.list.zh /etc/apt/sources.list

so that you can run apt upgrade painless
then run ./install.sh to install lima

What did the installer do:

  • add cpi to the render group,thanks to @slock

  • apt upgrade the system,it is necessary

  • cp kernel 5.3.6 to /dev/mmcblc0p1,thanks to @shell,I want to use5.4,but was too lazy to compile it from scratch,lol

  • cp lastest mesa 20.0 git dev(2d971cc1ca) to /usr/lib/lima/

  • cp dri so files to /usr/lib/arm-linux-gnueabihf/dri/

  • cp retroarch 1.8.1 release to /usr/local/bin,retroarch.cfg(directly copied from @javelinface deot image)
    to ~/.config/retroarch

after installation,reboot once

as @CommanderKitler said, use inxi -G --display to determine if is using lima

during the whole process,especially the apt upgrade
X may crash
wlan0 maybe down ,if you met the apt upgrade errors about wicd stuff, then

sudo ifconfig wlan0 up
sudo dpkg --configure -a

to continue , then re-run the lima_v0.4.bin or the install.sh inside lima_v0.4_20191223.tar.gz

Met any prompts to let you chose if keep the local version configs or YES or NO
just chose keep the local version and NO, basicly it’s all the default action
thanks to @bmos

I actually apt upgrade twice, the first time,xorg upgraded from 18.x to 19,then in the second time,finally xorg bumped to 20.x ,don’t know why

It is important to use USB ethernet to do this job at all the time!! if Wi-Fi goes down, USB rescues it

all the tests was doing on clockworkpi os v0.4

if you are not sure about the process, then wait for me to build a whole new os image contained the new lima stuff

after this installation, apt upgrade won’t broke the lima, you can still switch to the native mesa(fbdev/fbturbo) in the launcher

thanks to all the guys made it happen

1 Like

I would strongly recommend everyone to download the 191111 version, and apply the above to it, since 191122 used a simple stop gap fix version, using the usr directory etc.

I’ll see if I can get a special “Christmas edition” out before Wednesday, with it all applied.

Watch this space! (Ugh I’ve gotten sick again … so may be slow. I blame too much gunpla/fumes lol)

2 Likes

THAT.
I thats why I couldn’t get it to work on deot191111.
All of that tinkering I did while I just had to add the user to the render group. oof. :weary:

I had a look through your lima_v0.4_20191223.tar.gz
So the added apt repo is only for people from china so they have faster download speeds?
Really weird that debian uses the same repo no matter where you are located. :thinking:
I’ve been using archlinux for the last 5 or 6 years where you have a mirrorlist where you can order the download servers from most preferred to least preferred.

And you added the newest mesa and xorg versions?
wouldn’t a security patch or a debian version upgrade break that too?
maybe you should add apt-mark hold mesa-* xorg-* packages.
It wouldn’t matter anyway security-wise as the patches would be for mesa 18.* .

In the long run clockworkpi should ship their OS img with an additional official cpi-repo with the mesa and xorg patches applied. Manually installing libraries like this on a distribution with a package manager will always leave room for the package manager breaking things. (Although my way of adding some guys repo isn’t really viable either. Who knows how long it will be online, as soon as the repo is down my setup would downgrade to mesa 18 and xorg 1.18 which will break lima.)

Anyways great job and much cleaner than my messy setup.

That sucks.
Get well soon.

1 Like

get well @javelinface

just got a gameshell and happy to join this community! been following this thread for the last week and excited to see there is a strong core group of ppl working on making things better for all. Looking forward to being part of the fun :slight_smile:

2 Likes

thanks
to change the default apt repo source.list for people in china so they can have normal download speed,I thought the whole world all know the reason, it turns out I was wrong again ,lol

You will suffer a painful download speed like 1024B/s , never could accomplish a simple apt job if the source.list is using a foreign debian mirror in china

to setup a deb repo is good way , like the packagecloud you used

1 Like

您好我是命令新手,是否有命令让我们这些新手按顺序执行,谢谢

I have the compiled kernel 5.4.x which you can download from clockwork-pi3-kernel

3 Likes

There’s a few prompts throughout the install (running these instructions directly after imaging 191111 version) should these be replaced with the new version during apt-get upgrade?

edit
after the first run of install.sh, using the default ‘No’ for file overwrite the cpi hangs on reboot. cannot ssh in via USB to recover. A few exceptions in the boot log. input plugin qobuz is unavailable: No Qobux app_id configured etc

@bmos Welcome to the fun! You came at a really good time! Heaps of really exciting stuff is happening right now. Heck, I should be seeing my family for christmas, but here I am; fiddling with the game shell!

Thanks for the feedback re: the boot hang. Good to know, so we don’t waste time after an apt upgrade.

The exceptions in the boot log are to do with the MPD which seemingly has been upgraded in Buster.

I put in an edit you can make in post 172 of this thread.

But I don’t know if that is the thing that’s causing a boot hang.
I’ve just tried it a few times myself, with different iterations of 191111 and 191122, answering to keep and/or replace configurations accordingly. I too have run into similar problems.
I think it’s safe to assume that the aforementioned update is more applicable to a stock 0.4 image, rather than this modified one.

I’ll try one more time with a stock DEOT image.
If that doesn’t work, I guess I’ll rebuild from a a stock 0.4 image, add in the DEOT interface/theme/icons, all associated *.love files, and recompile the kernel with the custom boot screens. Ahh to think, all of this started out as a featured DEOT version to work with.

I would say that the 191122 version is probably the final version, purely intended for people who want to have a device to play games; since apt upgrading will essentially break the lima/mesa files. I’ll start work on something else from now on.

@junjie_shao There will no doubt be a complete official download image out that you will be able to use. Possibly wait for that. Otherwise, for now look up how to SSH into the game shell via USB. If you can get that far, the rest should be fairly straight forward.

I haven’t used windows in a while, so I have no idea if the above is still applicable. If you’re on a mac, you can just SSH into it using terminal, the normal way.
Afterwards, you’ll need to copy the self extracting binary to the game shell. Use whatever program you use to transfer roms etc.
Next you’ll need to type some things into the command line. I’ll just copy a screen cap of what to do next here:
Screen Shot 2019-12-25 at 12.41.12 pm

  1. First command, ls: Just verifying to see if the binary is there.
  2. Second command, chmod: changed the mode of the binary to make it executable.
  3. Third command, ./“filename”: Executed the binary to install it.

That’s just a basic run down. See how you go from there.

1 Like

sorry man , I only tested this installer on clockwork os v0.4 , not on deot

but if you chose all NO during the process, I think at least usb ethernet should work

2 Likes

@javelinface ah thanks good to know :slight_smile:

I’m still new so forgive me if this is mentioned all over already but what are the advantages to DEOT (stock version) over vanilla 0.4?

@guu ahh okay. That makes sense

I am unsure which is the correct link to download. Is it in the very first post by javelinface?

Hullo, welcome to the forums!!

Boy is this thread getting convoluted! Unfortunately when a post is more than a month old, it can’t be edited.
The links in the first post are indeed still valid, and is the correct version. As long as it’s the 191122 version, you’ll be set for the version I made this thread for.

I made another post with the exact file, just shared and mirrored by other users to help with download speeds in international regions; in particular people in China who are afflicted with the great fire wall.

Here’s the post:

The most recent stuff by @guu is a patch to be applied to the stock version 0.4. It won’t work on this custom DEOT version, however the DEOT version has 90% of what has is applied included anyway. What if doesn’t have is the custom repository, and the ability to do apt upgrade etc. If you’re just interested in playing games, this is probably an easier option, as the update takes about an hour to do, with a bit of troubleshooting, and knowledge on how to use a command line etc.

Hopefully this cleared things up. :slight_smile:

@bmos
This version has a few things setup that are mentioned in threads, but from trying to help other forum members, seem to cause a lot of headaches setting up. I’ve written them all out in the first post here:

As the title of the thread implies, the main attractions over a vanilla 0.4 installation are:

Custom D.E.O.T. V1.0+ : it uses the customised DEOT interface, with a dark theme, and a hacker like aesthetic

Clockwork OS v0.4 image : it is technically still the same as vanilla 0.4, just with extras updated

With Updated Kernel 5.3.6, Latest Lima Drivers, : this is the really recent stuff people have come together to work on, making the graphics drivers run faster essentially

RA1.8.1, : this is Retroarch, which is the core of what a lot of emulators use to run. The stock one in 0.4 vanilla one is extremely outdated (1.7.6) with less options available (eg no XMB) and an outdated config file. I have updated both.

Mupen64+ : mupen 64 is the N64 emulator. It doesn’t work by default on vanilla 0.4, and requires a lot of fiddling and configuration.

And much more! : the rest of the things are quality of experience updates I have applied to overcome a lot of universally experienced problems. Other things include doom wrappers being set up to natively play ID software games

(Current version: 191122) : this is just the build number, using the date I built the images as a reference point. There hasn’t been anything significant to add since last month, without me having to start a new build from scratch, using 0.4 as the base. I would consider it the final build in the DEOT 1.0+ line, at least coming from me.

I would say that for a beginner, this is a great image to get people started with the most features possible, particularly if you just want to play games, and have things running fast. I have read most of the criticisms people have had about the Gameshell by people; both in the forums, and in online reviews, most of which could be overcome by looking up solutions in the forums. Some things are also out of date and no longer applicable. It’s hard to find things, unless you know what you’re looking for. So I made an attempt at making a custom image that does all of that for you.

Vanilla 0.4 is fantastic if you want to learn how to compile and build things yourself, adding things as you see fit. For that reason, I have also provided links in the first post for you to follow, so you can pick and choose what I have installed, and apply things to your own vanilla 0.4 image. Some things can take hours to build, but it’s a great learning experience none the less!

Hopefully that didn’t just confuse you more! (I talk too much! I am so sorry!!)

Hi ! Let me know if I should host some more images, no problem for me! I am working on the private server for even more speed in the EU zone and possibly Americas but i need to tinker with the platform a bit before I release it. Current commercial service still works and has room for some more images if you’d like to have some mirrors for your work.

1 Like

@javelinface thank you for the detailed breakdown! I was also curious what the DEOT image (no modifications) vs CPI 0.4 image differences were besides the theme. But I guess that you’re saying there isn’t otherwise. :slight_smile:

I’d probably like to contribute as well when I can too

1 Like