clockworkpi

Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

Fantastic! I’m a huge fan of your user friendly CLI echo notifications in your scripts as well, so will probably keep them there. :slight_smile:
Thanks for saving me the trouble of finding the script. It’s on my todo list! :slight_smile:

1 Like

You’re welcome :slight_smile:

1 Like

This is awesome and a much appreciated contribution. I am a noob so have run into a bunch of bugs using your image but the tinkering and learning is part of the fun! Thanks!

1 Like

@Ahrjaydee Thank you so much!! Glad you’re enjoying it. :slight_smile:

Please let me know what the bugs are, and I’ll tinker with it to fix it, if it’s on my end!! That’s the beauty of the community. We ARE the beta testers! Haha.

That said, also compare it against the stock DEOT and 0.4 image. I won’t be able to “easily” fix anything that’s inherently wrong with the stock release.

Also check out @Rebusmind ‘s custom 0.3 image, as some people report a better experience with the earlier version. Personally I find them to be practically identical stabilitywise. 0.4 just has a few more features, and more current upgradeability/compatibility.

I’ll help out as much as I can! Most crashes/bugs appear to happen in Retroarch. In particular image stretching is less than ideal for text. For now, use Lima for anything besides Retroarch, and potentially change scaling to only be a whole number integer variable.

It sounds like a new release with an updated kernel and graphics driver is right around the corner. I’ll put something together similar to this once it comes out; using the DEOT interface, and the custom launcher chooser as mentioned in another thread.

Sources for all things referenced here are listed in the first post. It’s also here so you can read up yourself how things are done, ask questions pertaining to your problem in the right thread, and even have a bash at doing it yourself. It’s the best way to learn! :slight_smile:

did find one issue so far, cave story doesnt load

Have a look at point 6. in the feature list from the original post.

Cave story uses Retroarch, so you need to change it to the FBTurbo driver.

That said, hold onto your horses. Retroarch 1.8.0 was announced earlier in the week. I’m in the process of compiling it now. That along with the updated kernel, and lima driver, we’re going to hopefully get a much more stable system. SOON!

this sounds awesome, love how usable the Gameshell is now, i’ll try the other driver for now and see what I get. well tried that and it does the same thing, dumps me out to the main menu (both when running DEOT launcher, going to try normal launcher now

1 Like

Thanks, @John_Bach! That’s what I’m hoping to do; make something that has some universally wanted and desired features existent in an image that everyone can use; specially since it can be extremely hard to troubleshoot for people having problems with their image, not knowing what they’ve done. If you’re having trouble trying to add any other features, or have anything installed that you believe to be essential, let me know. Judging by your posts, you seem be quite the tinkerer!

Interesting! For my original card I dumped my image from, it’s fine. But when I burn a new one, it crashes! Sounds like a permissions thing with the game files or something. Thanks for pointing it out. I will investigate deep into it!

Also, ha! I think I’ll need to manually change my git-pull server location to update to 1.8.0 RA - just did it last night, and got a fresh 1.7.9. Good news is, I’ve isolated that it’s not a problem with my RA installation re: Cave Story.

Didn’t upload yesterday. Being sick means, suddenly you just need to sleep. On the other hand, it also means that you can take the day off from work. That’s what I’m doing today! Sorry for the delay. New download should be up soon. Might try using google drive or iCloud. Drop box has gotten kinda crap lately.

I’m also going to give a good solid bash at making all the missing icons myself. I’ll put it as a separate skin file, in case anyone wants to have a 100% stock feel; including missing icons.

Hello, @javelinface
your os image is to big to download from China, could you please share your retroarch.cfg for v1.8.0, I have tried many cfgs, but none of them works(cannot open at all or asking for login),I’m running OS v0.4
Thanks!

sounds great, i’ll be on the lookout

any word on the update? :>

Hullo! Still trying to get the 1.8.0 Retroarch working, and Cave Story with Lima! Don’t worry; I’ve been tweaking things at every spare moment I’ve got. Otherwise, the other things I’ve done on the 31st of October have been covered. :slight_smile:

@jszsj As for a smaller version, and/or just the config file for 1.8.0 - I’m working on that too! I can provide one for 1.7.9 however.

https://drive.google.com/drive/folders/1xjuLFPvbtcq3FDDYCX-GI1wTCXX4XB7n?usp=sharing

(In other news, I’m not sick anymore! Yay! I can keep my eyes open again) (oh… but also… death stranding comes out tomorrow… yeah my weekend might be “occupied”)

What are the download restrictions in China? Would it make a difference if I split the file, and had you combine it? I’ve had to do this in the past, for submitting large files at uni etc. Never thought I’d have to do it for pleasure.

yeah that game looks interesting but I have xbox one and PC lol. well work on it when ya can, looking forward to something new for the gameshell

Haha in an attempt to return the image to its stock state, I accidentally deleted “nxengine_libretro.so” from apps/emulators. That’s why Cave Story wasn’t working haha! Same thing happened to Nyan. In addition, I updated it to whatever the latest version was; changing to the neon repository. It seems a lot more stable using the Lima drivers now.

I was tearing my hair out all week, trying to get it to work! Good news! I’ll finally be able to upload the latest version of my image now!!!

I doubt this was a pressing problem for anyone, but for the record, I just downloaded the core via Retroarch, and just copied it from the config/Retroarch/cores directory to the aforementioned emulators directory.
Seriously, I’m tempted to change the default core directory via the action files to the Retroarch cores directory; or vice versa. It just doesn’t make sense, using cores from Retroarch, while using Retroarch and having to have them somewhere other than Retroarch. (Wow that’s a lot of Retroarch mentions)

Speaking of Retroarch, 1.8.0 wasn’t behaving. I’ll keep fiddling and eventually have something uploaded that’s useable. Keep in mind, it’s just there to play with. It probably won’t run any better. Just have more fun features. Also, 1.8.1 is now released, so there’s that too.

Likewise, just in case anyone’s having trouble with the new kernel installation, I’ve installed it in the current version. If it’s bad, I’ll omit it from the next release. Admittedly, I haven’t actually tested it, but eh. I was bored. :slight_smile: see how it goes. It may have been what brought stability to Cave Story using Lima Drivers. I changed a lot at once so didn’t actually test it scientifically. My bad!

I’ve uploaded the current version via google drive.

https://drive.google.com/drive/folders/1xjuLFPvbtcq3FDDYCX-GI1wTCXX4XB7n?usp=sharing

Hopefully there won’t be any problems. And maybe, it will overcome whatever limitations exist in china?

1 Like

great how do I download it? no dl button

Are you referring to the new image, or the nxengine_libretro.so? If it’s the latter, you can find it here: https://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/

Can you see the google drive link? It should be linked to a Gameshell directory. The image will appear there. You’ll need to right click it, and say for it to download.

If it’s too hard, I might just make a burner mega account, or a spare drop box or something.

I’m probably going to upload another image, come the weekend. Testing a bunch of things i implemented tonight, AFTER I dumped/compressed/uploaded the images. Ugh, that took forever.

But yeah, if you can, test out the one that should upload within the hour. Test it like mad, so I can put any fixes into the next release! :smiley:

the file looked too small was all :>

Are you referring to the DEOT image, or the NXengine core?
If you were referring to the image, give it a bit more time. It’s still uploading. Australia’s internet is SLOW!
It’s 33% done as of typing this.

Edit: Argh, looks like I didn’t have enough storage space on my google drive. Didn’t complete uploading last night. I’ve just restarted the upload, clearing off A LOT of space. Fingers crossed it works this time. I’ll check back here after work.

Edit 2: I’m home from work. Despite clearing a lot of space, Google Drive still insists I don’t have enough space. Looks like I need to tell it very directly that I have freed up space AND THEN upload my file. Argh. Huge apologies for the delay. I might as well just use dropbox while I sort out this hell hole of a mess. Or even iCloud. Watch this space.

oops thought it was done :>

AND it’s up. (finally)

If anyone used the previous DEOT v1+ 191019, and can comment on the stability of the lima driver, I’d be curious to hear back.
The main thing I changed was just updating the kernel to 5.3.6.
I’m personally finding that I can run a lot of the Retroarch emulators without the video freezing, and I’ve had to do A LOT less hard resets.
This could also just be due to using the Neon emulators too.

2 Likes