GameShell OS image files (v0.5)

Was this on a 0.4 -> 0.5 upgrade, or a fresh image?
The standalone gpsp+ once gave me that message a long time ago. I believe I had to move my gba bios files to the correct location. For gpsp+ at least, it needs to be in the same directory. Have you moved the default location of any files or directories? Changed directory names?
Mgba is a Retroarch core, so the bios directory is dependent on where you defined it in the config. I only use mgba for GB emulation, since I prefer the way it handles GBC and Super Gameboy emulation. What were you using it for?
This OS is basically the same as 0.4, just with a few updated drivers, cleanups and updates to Retroarch.

Hi,
Fresh 0.5 image
mgba and gba bios are in the same location
gpsp and gba bios are in the same location

I use mgba for GBA

I’ve just installed a fresh image
The apps/emulators directory is empty
I transferred a rom over; Mother3.gba
I ran the first core; mgba. It worked without even having to download/move any BIOS files over
I ran the next core; gpsp. It didn’t work, as it needed a BIOS, and had a version conflict. See below.
I ran the next core; gpsp+ standalone. It worked, and also automatically had a BIOS file in the installation zip file, installed in the same directory; apps/emulators

The default location for GBA BIOS on a fresh 0.5 installation is not the same directory as the core file. By default the BIOS are all required to be installed in the /home/cpi/apps/emulators/BIOS/ directory. This is for cores that are used in Retroarch. It is defined in the config file. You can confirm and change this in the Settings>Directory>System/Bios entry in Retroarch.
The standalone gpsp+ needs the core to be in the same directory.
You will need to have gba_bios.bin in two locations:

  1. /home/cpi/apps/emulators/BIOS/ for gpsp (Retroarch Core)
  2. /home/cpi/apps/emulators/ for gpsp+ (Standalone)
    As stated above, MGBA generally doesn’t need one.

Delete the retroarch gpsp core that is automatically downloaded. It is using the wrong version. You need this one: https://www.dropbox.com/sh/onjshlt5940z24b/AABNFzD0D3jKjrS40e6bmGaLa?dl=0

You can also find it here:
http://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/gpsp_libretro.so.zip
(@guu it might be worth updating a lot of the action.config files to have the updated download location in next update)

The action.config file that automatically downloads the core is using the older location that does not work:
https://buildbot.libretro.com/nightly/linux/armhf/latest/gpsp_libretro.so.zip
Do not use this one. This is the one that got installed incorrectly by default.

I would go so far as to redownload the mgba core as it is also using the wrong file, despite working. You can find it here:
https://buildbot.libretro.com/nightly/linux/armv7-neon-hf/latest/mgba_libretro.so.zip

Let me know how you go.

1 Like

Its not for Retroarch cores, these work, its for the Stand Alone Emulators

MGBA Is a retroarch core
gpsp is a retroarch core
gpsp+ is a standalone emulator

These are what come with a stock 0.5 installation.

I use this for MGBA:

I use this for gpsp:

gpsp standalone is working on my installation with zero intervention
try reflashing

What does your .sh look like?

I’m not using a bash *.sh script. I’m using an action.config, referencing the app.

ROM=/home/cpi/games/MGBA
ROM_SO=/home/cpi/apps/emulators/gpsp
EXT=gba,bin,zip
LAUNCHER=
TITLE=GPSP Roms
SO_URL=https://github.com/cuu/emulators/raw/master/gpsp.zip

I will try that later before reflashing.
And do you use mgba standalone ?

No. There’s no benefit for me, vs gpsp standalone. I only use mgba if I want to play GBC/SGB/GB roms. Using it Retroarch presents no speed problems, given the nature of the Roms, and gives far more benefits re: shaders, cheats, achievements, net play etc.
I prefer to only use standalone emulators if it presents itself as a means to increase sub par performance; never just for the sake of it.

Ok, thanks, i will try that later and report back.
Thanks for your time. :slight_smile:

1 Like

why not use gpsp retroarch core ? the one on the buildbot up at more than 200 fps when using fast forward
it’s pretty usable, i play with it with only 2 600mhz cores

1 Like

^^ +1 Agreed!
I think there are many users who use standalone emulators under the pretence that they run faster.
This is not always the case. But it’s almost impossible to convince people otherwise.

We should invite Groguard to this community, unfortunally he doesn`t have a Gameshell


3 Likes

Well I am open to be convinced otherwise.
If the buildbot gpsp core is the fastest I will use it then.
Its just that sometimes there is so many opinions on certain emulators that we get lost in all of this.

It would be really helpful if someone took the time to test and document all the emulators options on the wiki. (And by all, i mean the default ones installed by the OS images and the alternatives that people are using, either via action config URL changes or standalone versions installed from somewhere else.)

That way the devs would have some idea of what to update in the next version of the OS, and all of us would be better able to choose which emulators to replace and/or install…

I can’t volunteer to do this though, as I’ve been spending a fair bit of time and having fun with the x86 stuff and some game ports. I haven’t had much experience with the various emulators yet.

3 Likes

I’d be happy to help.
We’d need to fix up some things first, such as the URL included fo download cores being outdated.
Retroarch is up to 1.8.4 now, while the stock OS 0.5 is on 1.8.1. Is updating Retroarch something that most people do?
I can provide my config file for 1.8.4. Just to make sure that reporter performance can be replicated on someone else’s machine.

Are there a lot of advantages to upgrade from 1.7.1. to 1.8.4 ?

Oops I meant 1.8.1 -> 1.8.4 . My finger slipped.
Mainly multi disk support.
The Mame digital analogue input support problem has been addressed re joystick mapping and key binding.
Also menu items are a lot more logically grouped. Eg synchronisation settings. It makes pinpointing where to optimise settings for better gameplay much easier.