clockworkpi

GameShell OS image files (v0.5)

well
if you had them updated/modified
you can send a pull request next time, :grinning: :grinning: :grinning:

haha I will have to edit them on on a stock 0.5 image - I’m currently using my modified image, where I’ve changed the ROM directory locations, and core locations heavily! But I’ll definitely do that to save you some time… when I remember! I should have some free time this Wednesday. :smiley:

1 Like

Please if you update the image change the version, don’t keep the same, else people are going to get confused on which one is which. Please update that version to 0.5.1 or something similar!

1 Like

Jumped into seeding the official 0.5 stock image, as the torrent was dead. Now with 24/7 gigabit seed.

1 Like

Did a clean flash of v0.5 and now I can’t properly set up mupen64. Prompted to set up this game automatically, then it instantly says “Invaid” (not Invalid). Any idea what could be going on here?

Thanks!

Welcome to the forums.
Re: mupen running, It needs some dependencies. Unfortunately, mupen never really worked out of the box. The auto config doesn’t work, unless you have the dependencies already installed. If it’s a new installation, then chances are they won’t be.
It’s also not the most user friendly interface, re: setting things up. You’ll need to do most of it manually. Think of it being included as an easter egg for testing purposes.

Try running this script;

wget -O /home/cpi/mupen.sh https://www.dropbox.com/s/uxerntgv8kpluzm/mupen.sh?dl=1 && chmod +x /home/cpi/mupen.sh && ./mupen.sh
sudo rm /home/cpi/mupen.sh
sudo rm -r /home/cpi/mupen/
wget -O -rf /home/cpi/apps/Menu/20_Retro\ Games/mupen64plus/action.config https://www.dropbox.com/s/932qp0yqjeta8ot/action.config?dl=1
mkdir /home/cpi/.config/mupen64plus/ && wget -O -rf /home/cpi/.config/mupen64plus/mupen64plus.cfg https://www.dropbox.com/s/9msh8d8js2tek9k/mupen64plus.cfg?dl=1

You’ll need to SSH into your gameshell to run this. It runs a script to install the dependencies, and also installs mupen64plus to the /usr/local/bin directory. This should make it run faster than the /home/cpi/apps/emulators directory; or so some people say. I can’t confirm either way.
The action.config file will be overwritten with one to reflect the “proper” location of mupen64plus, as per above, along with cleaning up the formatting a bit in general.
The mupen64plus.config file will be overwritten with one that I’ve been tweaking over time to run nicely. It is configured to be used with the lightkey attachment.

If you have any more queries, probably would be better to either search up an existing thread, or starting a new one. Setting up mupen64plus is something that should be easy, but for some reason or another, people have difficulty. I also made a separate custom image with it pre installed, along with some other things.

Hey, thank you so very much for the quick and detailed help. Following these instructions worked perfectly. Performance is pretty good (better than my RG350) though some shaders are a bit wonky.

New to all this linux and ssh stuff but I’m slowly getting there. Thanks again and cheers!

1 Like

This instruction is no longer needed, as I fixed up the typo I made in my previous post.

Here for historical reasons

Whoops! I made a typo. There might be a stray action.config sitting in your retro games directory.
Redownload it to the right place with this:

And of course, remove the stray file with

rm /home/cpi/apps/Menu/20_Retro\ Games/action.config

May I know how to trigger the file system auto expansion manually?

This was taken from @hpcodecraft’s script:

#!/bin/bash

GREEN='\033[1;32m'
NC='\033[0m'

printf "${GREEN}Installing dependencies...${NC}\n"

# Install growpart util
export DEBIAN_FRONTEND=noninteractive
sudo apt-get -y install cloud-guest-utils

printf "${GREEN}Growing partition...${NC}\n"

# Grow root partition
sudo growpart /dev/mmcblk0 2

printf "${GREEN}Resizing file system...${NC}\n"

# Resize file system
sudo resize2fs /dev/mmcblk0p2

printf "${GREEN}Cleaning up...${NC}\n"

# Uninstall growpart package again
sudo apt-get -y remove cloud-guest-utils

printf "\n${GREEN}Done! Reload UI and Check Settings->Storage 😊 ${NC}\n\n"

so after I enter the script for the dependencies do I copy paste this entire thing in this?

Aha, that was a one off quick amendment I had to make. Initially, I made a typo, saying to download a file to a location. I fixed up the initial post, downloading the file to the right place and deleting the file that got downloaded to the wrong place.

You shouldn’t need to run that second bit. :slight_smile:

so just run the script on top from the initial post?

That’s correct! I’m assuming you’re running a stock 0.5 image? Also perhaps continue this in the thread you started. This is getting a bit off topic.

yes I am currently, I am waiting for the script to finish running again via the original post

this ish takes forever lol

Don’t forget, you can edit you posts. :wink:
For anyone else following the breadcrumbs down the track, here is the post that I’m talking about.
@Larry_Covington - could you continue the discussion here? Although you shouldn’t need to, since that script should do the trick. :slight_smile: (and yes, it does take forever. Be patient! It will be worth it!)

thank you very much for the help I just readded the script and the new edit from the (Dropbox part), so now do I add the last line on this edit with the (rm) on it?

this line
rm /home/cpi/apps/Menu/20_Retro \Games/action.config

Dear All, I have a request for help. I bought Clockwork. Downloaded 0.5 image. Downloaded balenaEtcher. Burned the image onto original SD card. And I can’t boot the Clockwork now --> nothing happens after inserting SD to the unit, and trying to power up. I have a second Clockwork with old 0.4 image SD card, when I swap this card onto the new Clockwork all works fine.

Am I doing something wrong? Checksum was OK. Is there any additional action to do to make the SD card bootable or something?