clockworkpi

GameShell OS image files (v0.5)

try

cat /tmp/x.log in ssh

to see if X is segment fault

This is the output I got:

The screenshots are in the wrong order, sorry.

can you run

sudo apt update && sudo apt upgrade 

and then re-run the patch_for_clockworkos_v0.4.sh?

and after ran the patch
run

sudo ldconfig
sudo reboot

I’ll try it tomorrow morning and let you know the results. Thanks for being so helpful!

Mupen64+ was never working on any release unfortunately, unless it was self built or pre made in a custom release. I’m looking to do exactly this, with the garage system.
Meantime, try this:
https://drive.google.com/drive/folders/1gdp6lrHK1bmBTM_CKiU7RNXKL-W8w0X3

Action config replaces the one in the mupen menu directory.
Mupen.sh is a script to install mupen dependencies. (You’ll need to sudo chmod +x the file to get it to be executable)
Mupen64plus is the program to run. Put it in the ~/apps/emulators directory.
Mupen64plus.cfg goes into the ~/.config/mupen64plus directory.

DM me if you need more help, since it’s kinda off topic in this thread.

Still it’s strange that the action file for Mupen64+ has been in the official releases, since off the bat, it simply doesn’t work. Well, all the files needed for it to run are above.

instructions on how to use the script for those interested

Righto! So the chmod command is what you need to do to change the mode of the file.
However to use this command, you will need super user permissions. That’s when you type sudo.
You will need to have a switch to choose what mode. Sometimes you put in a bunch of numbers. To do what you need however, you just need to put in the switch +x.
You need to point out where the file is located. I just run it from the user home directory, copying it directly to the CPI user. You can save having to type out the entire path of the user directory, simply by using the tilde key, ~.
Put it all together and you get:

sudo chmod +x ~/mupen.sh

It will more or less be instant after changing the permissions. Now you just need to run it! There are a number of ways to execute it. Using the command bash will allow you to run it assuming it is from the home directory. Since the file is already there, and I like to have more control over where it’s executed from, you can use the ./ command.

So assuming you’re already in the cpi home folder, type this:

./mupen.sh

And if for some reason you’re not, or if you ever need to run something from within another location, here’s the bash command for your reference:

bash ~/mupen.sh

Hopefully this shows you how to do it, and also teaches you a bit more about how to use Linux! :slight_smile:

2 Likes

There’s just so much that we don’t know people could have done to customise their systems.
Like an OS upgrade on a computer, it might almost be worthwhile to aggressively cull everything besides what is in the games and music folder, replacing it all with the current version. That and config files and bios files.

Also re the source.list pointing to the Chinese mirror (no doubt to help those afflicted by the great fire wall of China), perhaps having a switch within settings to toggle which mirror/repository could be useful, and avoid needing to have two separate releases for both China and the rest of the world. (Continuing @arthur’s post)

1 Like

yeah , we are fixing the source issue by remaking the os image

and I am not very sure what

means,lol
english is not my first language

and I also tried your mupen64 on os v0.5, at least it can run , so I will relpace my mupen64 with yours so that users can have a n64 to run

you are my saver,really

2 Likes

Oh!
I’ll try and rephrase it. (I talk too much lol)
Make the update wipe everything EXCEPT for ~/games and ~/music.
Also keeping ~/apps should retain people’s BIOS files, since everything including PCSX’s bios should be held here.

1 Like

ok,now I understand , lol

2 Likes

i tried to upgrade from v 0.4 to 0.5.

  • i downloaded “patch_for_clockworkos_v0.4.sh”, Copied it to GameShell and made it runable with “chmod +x”
  • executed “sudo apt-get update && sudo apt upgrade”…

unfortunately, at about 64% of upgrade the GameShell droped usb/ethernet connection, because of upgrading smth. network-related.
so, had to wait about 1 hour, hoping that it’s enough to complete the executed commands.
i tried to connect via WiFi, but had timeouts. on ethernet GameShell refused SSH connections almost immediately.
there was no choice but reboot the GameShell. then i stuck with “You have new mail.” screen, with some non-sence in “x.log”.
so i executed “sudo apt-get update && sudo apt upgrade” again,
and run “patch_for_clockworkos_v0.4.sh” on GameShell.

after reboot i stuck with “You have new mail.” and X segment fault in “x.log”, and clue about video driver crash in “Xorg.0.log”.

then tried to instal “lima” driver

and after reboot, i was able to see the launcher UI.
checked the “About”, and “0.4” displayed there,
so i decided to try the “patch_for_clockworkos_v0.4.sh” once more.
and… stuck with “You have new mail.” and X segment fault with video driver crash again :slight_smile:
so, installed “lima_v0.4” one more time.

so far, the launcher works. i see “Warehouse” menu, but “About”, still displays v “0.4”.

Okay. I tried multiple times and I’m still stuck. From what I could see everything got updated except for 16 packages.There were times when it asked if I keep or update a local package and I said yes to updating one out of the three times this happened.

Okay so there is a problem with the OP-1 theme when upgrading, but is it working correctly with a clean reflash?

If anyone create a torrent, please tell me I will add it to my seeding box which is also seeding all the previous versions

Not for me. I clean flashed twice because the first time switching to OP1 doinked my system into that Loading screen.

As I mentioned earlier in the thread, there were problems with the OP1 theme when doing a clean flash.

The solution to getting out of a broken state after enabling the OP1 theme is to remove the .gameshell_skin file:

@guu has posted that there’s an update available for Launcher that fixes this:

You should be able to install 0.5 and then update Launcher to the latest version on Github from the Settings > Update launcher menu (or by manually doing a cd launcher && git pull assuming you haven’t made any changes in your launcher)

the patch or lima_v0.4_20191223_2.tar.gz won’t change the os version number

during the apt upgrade
chose

keep or update a local package <- keep

and all other option is NO

and I am not sure how to fix your issue now

If I were you I’ll give a try on

since there is no better way now
and why there are 16 packages not updated? some errors occured?

if that so
try to reconfig the apt to fix

what exactly do you mean by

I tried it. I can access the menu now, so I think it worked.

1 Like