clockworkpi

Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

您好,请问可以分享一下,新的lima驱动再o.4系统上的安装方法吗,因为我安装的系统有大量的设置,所以暂时没有换系统的打算,谢谢。

Hi, probably better to not thread jack this with a post explaining how to apply everything. That said, in the original post, I have provided links to all of the threads in this forum that describe how to apply them all individually. I’ll provide some links below.

In particular, you will need to install a new kernel. Don’t forget to backup before applying this:

Then afterwards, follow this post from this thread. You’ll need go build it yourself:


(Just modify some of the code with this)

I’m not sure what you’re planning on using the new Lima drivers for, but one thing it works great with is the mupen64plus emulator. You’ll need go build it yourself:

Ive tried to make this thread both a culmination of a lot of things that people may have trouble doing, or simply can’t be bothered doing. It also serves the purpose as a means of self education, with links and sources to all features applied. If there’s anything in particular that you have in your setup that could be something I could add to this release, let me know! Perhaps I could make this image cater to your needs! :slight_smile:

I have had the “ba ba ba baaa baaa, ba Baba ba baa” theme song in my head all day thanks to this!!! Haha! Nice. Hopefully your image is downloadable in China.

What’s the general deal with China, preventing them from downloading large files, and requiring a proxy to download from Dropbox/google drive? I’m not aware of the laws/regulations.

@guu As usual thank you so much for taking the arduous 6 hours to download this, apply your changes and no doubt spend even more time uploading it!
@Wizz If you can upload guu’s file to your server, this will help distribute the image to as many people as possible! :slight_smile:
Thanks again!!!

Ok will download and host on the same link :slight_smile:

Both to be found here;
https://pcroz.stackstorage.com/s/a26iBYxvkQ5VSgS

1 Like

非常感谢您的讲解,我已更新5.3.6内核,但依然看不懂lima驱动是如何更新的,不过非常感谢你的回答

SSH into your game shell, and type this into the command line. This was taken from the link I put in my post above, and directly from @guu’s post a few replies up. I have just modified an additional mkdir to allow the files to be built somewhere.

If you don’t know 100% what you’re doing, do everything 1 line at a time, to make sure there are no errors etc. Some of the commands require a Y/N input. If you just paste everything in, it overrides these, and aborts the process.

You don’t need to type in the ## comments. They’re just comments.

## install the new libdrm
wget https://dri.freedesktop.org/libdrm/libdrm-2.4.100.tar.bz2
tar jxvf  libdrm-2.4.100.tar.bz2
cd libdrm-2.4.100
./configure --libdir=/usr/lib/arm-linux-gnueabihf
make
sudo make install
cd 

## install the mesa master branch 
sudo apt install g++ meson python3-mako zlib1g-dev libexpat1-dev libdrm-dev flex bison libx11-dev libxext-dev libxdamage-dev libxcb-glx0-dev libx11-xcb-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-present-dev libxshmfence-dev libxxf86vm-dev libxrandr-dev

git clone https://gitlab.freedesktop.org/mesa/mesa.git
cd mesa
mkdir build
meson build --prefix=/usr/   -Dbuildtype=release   -Dgallium-drivers=kmsro,lima,swrast -Dosmesa=none -Dplatforms=x11,drm,surfaceless -Dllvm=false

sudo ninja -C build/ install

sudo mv /usr/lib/dri/sun4i_drm_dri.so /usr/lib/dri/sun4i_drm_dri.so.old

sudo mv /usr/lib/dri/sun4i-drm_dri.so /usr/lib/dri/sun4i_drm_dri.so

sudo mv  /usr/lib/lima /usr/lib/lima.old/

sudo reboot

哇,非常感谢,这正是我所需要的方式。感谢你的回复,我一直在关注gameshell的发展方向,有你们在真好。

1 Like

Ha, don’t thank me. This is exactly how @guu had it written out a few posts up. I merely pasted it in. Full credits should go to him.

Like I said above, the idea behind this thread is to get a whole bunch of great ideas, and compile them into one image that is easily accessible by everyone. Instructions that are as clear as guu’s often get lost, since people find it hard to know exactly what it is they’re looking for. I’m glad the community could all come together and help like this.

Was there anything in particular that you have installed and use on your image that justifies not having a fresh installation like the one in this thread? Just so I can have some kind of inspiration of what to include in a future image.

您好,我在系统中没有安装很特别的程序,只是下载了很大量的仿真器,而且tf内存卡的大小是128g的所以,能希望在不换系统的情况下更新lima的驱动程序。

您好,我还是更新失败了,在 install the mesa master branch 这些步骤中频繁出现错误,但我下载了您上存的系统映像了,针对n64运行的情况与之前的版本对比效果有所增加,我运行了1080度滑雪,贴图不再黑暗,音频清晰,运行帧数有所提升,遗憾的是距离完美运行的程度还有很长,再次感谢您的付出让我看到了n64完美运行的希望,谢谢

1 Like

Haha that’s another reason I made this image. Particularly mupen64, I’ve tried to help people get it working in other threads, but without knowing their exact system configuration etc, there was no way to diagnose individual problems. So having an image with it all built saves that hassle.

Try building mupen64 again from scratch after upgrading the Lima drivers, as suggested by @shell a few posts up. Sounds like shell was also having some problems with mupen64 using the Lima drivers.

I’ve tweaked my mupen a little bit here and there, including but not limited to my config file. If you just want to try and modify your existing 128GB card, I have uploaded a few files that could get you started.

https://drive.google.com/drive/folders/1gdp6lrHK1bmBTM_CKiU7RNXKL-W8w0X3

Put the config file in the .config/mupen directory.
Replace the action file in the apps/menu/(then wherever your mupen is) directory
The mupen file is the one I’m using. Put it in apps/emulators.

It’s still not 100% ready for prime time with every game, but the compatibility and black boxing issues have certainly improved like what you mentioned!

With the progress that has happened in this thread, my guess is that a new 0.5 release is right around the corner! Might be a good idea to have a backup plan for saving all your games; ready to re upload them to a new image.

As for issues with installing the Mesa master branch, try just doing the first line of code only:

sudo apt install g++ meson python3-mako zlib1g-dev libexpat1-dev libdrm-dev flex bison libx11-dev libxext-dev libxdamage-dev libxcb-glx0-dev libx11-xcb-dev libxcb-dri2-0-dev libxcb-dri3-dev libxcb-present-dev libxshmfence-dev libxxf86vm-dev libxrandr-dev

You may get asked a y/n prompt. Answer Y. Occasionally it will just timeout and say abort. Be on standby at this step, ready to hit Y as soon as possible. Eventually it will work. I’m not sure if it’s a timeout problem or just random luck. Either way, persevere!

I haven’t actually tried this on anything but my image, so there could be a chance this is using a dependency I have previously installed. Again, it’s hard to know everyone’s individual setups.

感谢,看似在我的gameshell上依靠您的提示安装成功了,再次感谢您的付出。

1 Like

Glad we could all help. :slight_smile:

On a side note, if anyone has been having trouble downloading the image from the google drive link from the OP (I can’t change the original post, since it’s now older than 1 month), I’ve provided some alternatives.

The image has kindly also been shared by other users in the forum, so try those as well; especially if you’re having trouble with download speeds, or regional firewalls etc.

@javelinface’s link: https://www.dropbox.com/s/4l1467cdy670j5d/deot_v1%2B%20191122.img.bz2?dl=0 (includes both guu’s modified image, and the original one without an expansion script) and https://drive.google.com/drive/folders/1xjuLFPvbtcq3FDDYCX-GI1wTCXX4XB7n
@Wizz’s link: (Europe)
https://pcroz.stackstorage.com/s/a26iBYxvkQ5VSgS
@guu’s link: https://mega.nz/#!9AliFIJa!QTTiI_VCPiD009DcqMAPGUHhVcI6BW_WqNVZkyMuVPM
@shell‘s link: (China)
https://pan.hanwangsoft.com/f/f76f2d0501094d5ca7e4/?dl=1
@CommanderKitler’s link: https://siliconlollipop.com/nextcloud/index.php/s/AYMFq9xRsjBbHba (Europe)
Alternative mirror of @CommanderKitler’s link: https://mega.nz/#!U6IknSpS!gKR8linzvUA6GHLwWUGnu4b4pdgIpV-ZlxvpbQq9s3A

The file should be 2.96GB. I believe @Wizz’s private server link is great if you live in Europe. @Shell’s file is suitable for people who are downloading from China. The others are just the standard mega, google and dropbox locations. @CommanderKitler’s image is a customised image, testing out some features, but also breaking a few others - It’s a WIP, so only download it if you are interested in development etc. See the link for more info: Custom D.E.O.T. V1.0+/Clockwork OS v0.4 image - With Updated Kernel 5.3.6, Latest Lima Drivers, RA1.8.1, Mupen64+ and much more! (Current version: 191122)

Don’t forget that you need to decompress the *.bz2 file before writing it to an SD card. The image will need to reboot twice in order to expand the partition, so let it do it’s cycle the first time.

Some people who have had trouble have had to perform a fsck. Not everyone does, but just going to mention it here just in case.

请问以上这些代码是更新lima驱动的代码么?我的系统是0.4的内核5.3.6

Is the above code a way to update Lima driver ?My system is 0.4 kernel 5.3.6。

Yes it is. But do a backup first. I have no idea what else you have done to your system. You could also just download the image and test it for yourself.

Like @guu said, it’s a way to “test” it, since it’s installed in the user directory. This means that if there are ever future pushes updates, they will get overwritten.

If you’re not sure of what you’re doing 100%, either wait for the official release, or test it using the image I’ve made.

Hmm I flashed this image to a 32Gb Sdcard but does not seem to work. It boots with to a Gcores Indusries splash but does nothing else.

Is there something I need to do to get it to work ?

It is the deot_v1+ 191122.img

Any ideas?

1 Like

Theoretically it should just be able to be written as an image and all should work. I haven’t tested the zeroed space and auto expand modified version. I’ll do that as soon as I get home.

But thank you so much for reporting this problem!!

I have a theory meantime. The boot partition might not have been written. It could be using an old kernel.

Also. Try rebooting. It could be the expander script doing its thing. Maybe write the image again and wait it out.

Its bad practice to run processes without user input, or without status indication.

Its possible to show the status on boot before loading the splash-screen. Because its basically the TTY, if you click buttons you will see the letters writing on the terminal.

1 Like

Thanks @Petrakis
The original version uploaded a while ago actually had a separate expansion script that the user could run to expand the space as required.

The one currently up is using @guu’s expansion script. In his original incarnation of this, he mentioned that the gameshell will reboot twice, then fill up the space. Unfortunately I couldn’t provide this info in the original post, since I can’t edit them after a month.

I’ll include a separate version that doesn’t automatically expand without user input if people would prefer; on top of the existing one. It will just be sitting in the Dropbox.

On a side note, after allowing the Gameshell to reboot twice on a freshly baked image, it is fully functional. I’ve tested it on three SD cards. A Sandisk 32GB ultra, the stock sandisk 16GB ultra, and Toshiba 16GB card. They are all class 10. I’m using a MacBook Pro’s SD slot, and the app ApplePi-Baker. I usually use and recommend etcher, but I’ve been using the former for a few other projects recently.
Possibly try again, or try a different card?

Let me know how you go @develroo.

1 Like

I did notice on the card /boot was empty I am guessing that was supposed to be a mounted partition. But the card only had one partiton on it. so…?

EDIT. OK so I re-imaged it… and then fsck. Boots fine now… But… I just noticed the A & B buttons are either reversed or the prompts are. Bug or feature? :wink:

EDIT 2: OK so they were set up as SNES by default that is what threw me. It is nice skin and works very nicely… Have no idea what the extra icons do as they are all in Japanese or something… But as far as the usual functions works perfectly. Cheers.

1 Like