clockworkpi

GameShell OS image files (v0.5)

this ish takes forever lol

Don’t forget, you can edit you posts. :wink:
For anyone else following the breadcrumbs down the track, here is the post that I’m talking about.
@Larry_Covington - could you continue the discussion here? Although you shouldn’t need to, since that script should do the trick. :slight_smile: (and yes, it does take forever. Be patient! It will be worth it!)

thank you very much for the help I just readded the script and the new edit from the (Dropbox part), so now do I add the last line on this edit with the (rm) on it?

this line
rm /home/cpi/apps/Menu/20_Retro \Games/action.config

Dear All, I have a request for help. I bought Clockwork. Downloaded 0.5 image. Downloaded balenaEtcher. Burned the image onto original SD card. And I can’t boot the Clockwork now --> nothing happens after inserting SD to the unit, and trying to power up. I have a second Clockwork with old 0.4 image SD card, when I swap this card onto the new Clockwork all works fine.

Am I doing something wrong? Checksum was OK. Is there any additional action to do to make the SD card bootable or something?

You need to wipe out sd card completely before install new image ( remove all partitions). Try to google “sd doesn’t show/have full capacity” or something similar…

I followed the instructions to upgrade my gameshell from version 0.4 to version 0.5 and now the gameshell doesn’t get passed the Happy Hacking message.
I used ssh to get into the gameshell. used wget to get the patch for v0.4 to v0.5 patch. Then I did the update and upgrade. Then I did a chmod to make the patch executable. Then I ran it.
After it was all done I changed the driver to the new lima driver in the gameshell’s menu system. And when I rebooted it, it just says happy hacking and you have mail. I can’t get passed that screen now.

What did I do wrong?

I think I have the same bug you do. What did you do exactly to fix your issue?

I would just use a fresh MicroSD. I installed a new OS on mine using Win32 Disk Imager and didn’t have any issues

1 Like

I was able to fix the issue I was having by just reformatting the sd card. Thank you for the reply though.

That is great to hear!

Sorry I didn’t reply. I didn’t see this until right before I went to bed. I think I figured out my solution though, if anyone still needs it.

My upgrade went smoothly, but I noticed it was still an old version of the GSP launcher, and required a git pull (and clearing the menu.json) to fix.

same am i also havung many issues concerning how to get the software update

1 Like

Hello! Welcome to the forums. :slight_smile:
From what I’ve gathered, performing the update from 0.4 to 0.5 is something that is more of a “power” used option, and one to use if you have a lot of data you want to keep. It also seems to be fairly hit and miss, depending on how the user has their system configured.

The definition of update also seems to be a bit confusing. The update option in the main menu is just to update the “launcher” and not any of the underlying OS.

The update from 0.4 to 0.5 is a script that you run.

The files included to be downloaded are an entire disk image to be flashed onto your SD card, erasing all of the contents in the process.
In general, I would say it’s better to just start from scratch, and flash a new image.

If you’re new do the forums, and disk image writing, I can see how finding clear instructions could be difficult. It’s something a lot of people just take for granted.

Here’s a link to a post containing some instructions for writing disk images. Scroll to the drop down menu under the heading “installation”

Note: the entire contents of your SD card will be wiped if you do this, so back anything you you want to keep.

1 Like

I have a question. On Youtube, someone named Taki Udon said vesion 0.4 has Mupen64+. He said there were some graphical errors. Are these bugs fixed in this version?

What do you need help with

Don’t click the link. Looks like a spambot.
As for your post, 0.4 has mupen, but the drivers made a lot of graphics appear “off”, eg, mariokart had black boxes around each racer, and smoke/fog in games just didn’t ever perform correct.
I wouldn’t use 0.4, since 0.5 has the updated Lima drivers for the graphics, and is actually stable. 0.4 has major stability issues when using Lima drivers.

Whats Lima? Is it important?

Taken from Phoronix.com,

It’s important, since without up fo date stable drivers, your graphics cores can’t function, and games/apps won’t work since it can’t call on specific libraries/instructions etc.

The old drivers were out of date because 0.4 was using an older kernel. If you look up the DEOT+ V1 thread, you can see the community’s progress towards making it work, and using a newer kernel.